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1.0. General Information  

1.1. Preface  

1.1.1. Reference and Function 

For tracking and recordkeeping purposes, this document has been assigned the following reference code: BID125628. 

This document is designed to support, drive and streamline user interface (UI) design and front-end development operations in an 
open, transparent and readily available fashion. The UI team heartily encourages constructive feedback, recognizing that 
communication is a prerequisite to consensus-building, mutual understanding and the overall cohesion and effectiveness of the 
group.  

1.1.2. Authority and Rationale 

The guidelines herein are not merely recommendations; they are standards. Follow these standards in all cases, without deviation, 
embellishment, second-guessing or selective application. Only rarely and under specific circumstances are exceptions allowed, and 
then only with the express consent of UI specialists. In the absence of further clarification from authorized personnel regarding UI 
issues, this document is the final authority on these matters. This authority is derived directly from management. 

Standards serve a vital purpose in maintaining consistency. Since learning curves are inherent to all software use, consistent UI 
principles condition users to expect certain predictable patterns in both presentation and functionality. Similar instructions, for 
example, worded in similar ways, should appear in the same font face, color and size in similar screen locales under similar 
circumstances. Furthermore, with consistency, the company’s image and brand are perceived as a coherent whole. This in turn 
conveys stability and assures the client that their trust in the company’s products is not misplaced. It fosters loyalty and cultivates an 
emotional bond with the brand. In short, consistently applied standards make for a better product and user experience.  
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1.1.3. Evolution and Availability 

This is an evolving document. With refinement and improvement, McKesson products adhering to its tenets will continually mature. 
The prime objective in this endeavor is, of course, to produce the best quality software on the market. The fluid nature of software 
development necessitates that these guidelines variably act and react to new conditions. Therefore, try to consult this document on 
a regular basis to remain up to date on revisions, additions and clarifications. Everyone affected by changes in this document must 
remain current on all standards. 

This guide as a single Word-formatted document is available through StarTeam as HECM UI Standards.doc (see below for full path).  

 Location: StarTeam: eig\HECM\doc\ProductMgt\User Interface\R1.0\UI Guidelines\HECM UI Standards.doc 

 Hyperlink: 
starteam://starteamapp.mckesson.com:49260/158;ns=Project;scheme=id/580;ns=View;scheme=id/5309754;ns=File;scheme=i
d;scope=full 

1.2. Background 

1.2.1. Scope 

Many roles attached to the project benefit from its existence. This document attempts to present standards in a straight-forward 
manner, with background, when possible, on the rationale and reflection behind those decisions. The reason for this is three-fold. 

 First, transparency. It demonstrates that decisions adhere to sound principles (UI best practices) and are NOT arrived at 
arbitrarily. This in turn instills greater accountability, accuracy and confidence through team-wide checks and balances. 

 Second, erudition. It elucidates the decision-making path, such that the underlying logic becomes second-nature and 
propagates through the team. This guide is NOT meant to be all-inclusive. It assumes that the reader is capable of 
extrapolating the reasoning beneath the guidelines, so that patterns can be discerned and similar solutions applied under like 
circumstances. 

 Third, efficiency. It streamlines development by reducing churn. By consensus-building through stakeholder buy-in early in the 
design process, standards can be established and locked down sooner. As a result, the rework rate plummets dramatically and 
the product moves more rapidly from idea to implementation. 

starteam://starteamapp.mckesson.com:49260/158;ns=Project;scheme=id/580;ns=View;scheme=id/5309754;ns=File;scheme=id;scope=full
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1.2.2. Authors 

All style guide changes funnel through the User Interface team to keep the quantity and quality of changes at a manageable level. 
This ensures consistency and helps eliminate the dissemination of contradictory or otherwise faulty information. Please thoroughly 
consult this guide before you contact UI with inquiries. The following are user interface designers in McKesson’s Alpharetta, Georgia 
facility: 

1.2.2.1. Christine Walker (Christine.Walker@McKesson.com) – (404) 338-3575  

1.2.2.2. Nick Zedlar (Nick.Zedlar@McKesson.com) – (404) 338-4311  

1.2.2.3. Bob Owen (Bob.Owen@McKesson.com) – (404) 338-2049  

1.2.3. Frequently Asked Questions 

1.2.3.1. Horizon Enterprise Content Manager 

 What is HECM?  
HECM is short for Horizon Enterprise Content Manager. Formerly known by its internal codename, ENIGMA, it is McKesson’s 
next generation content and workflow management computer program. It follows in the footsteps of the company’s 
successful software solution widely used throughout the medical sector, Horizon Patient Folder (HPF). 

 What are the general features of HECM?  
HECM is meant to be a generic (domain-independent) document-imaging content manager with basic core services such as 
COLD document-imaging, native content viewer, version control, and workflow and work list task management. 

1.2.3.2. Updates and Maintenance 

 What constitutes an update? 
An update is considered brand new content or a significant change in meaning or way of presenting something (for example, 
adding screen captures). Minor formatting, wording or spelling corrections are NOT marked as updates. 

 How do I know what’s been updated? 

mailto:Christine.Walker@McKesson.com
mailto:Nick.Zedlar@McKesson.com
mailto:Bob.Owen@McKesson.com
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It’s easy. Check the Table of Contents (TOC) to see at a glance what sections have been updated since the previous version; 

they are marked with the  symbol. Parent headings are not update-marked unless every child section under it has been 
updated. In this case, the parent and all children are shown as updated. 

1.2.3.3. Submitting Feedback 

 What types of things are appropriate to communicate to the UI team? 
Virtually anything that pertains to the form and function of the application user interface on the front end and this Guide that 
documents them. Welcome are praise or constructive criticism of spelling, word choice, control types, colors, fonts, images, 
layout—anything you can think of that would make the product itself or the User Guide better and easier to use. 

 Who do I contact regarding the Style Guide? 
See Authors above. 

1.2.3.4. Using the Guide 

 This is a big document. How do I find what I’m looking for, get there fast and get out? 
Your best bet is the Table of Contents. Navigate via the first- (chapter), second- (section) or third-level (subsection) heading 
in the TOC to jump to a topical part of this document. 

 What are the hyperlinks in this document for? 
In almost all cases, these are bookmark links that jump within the Style Guide itself, usually to provide more information 
about a particular related or relevant topic. Occasionally, links to external content can be found, which always explicitly spells 
out the URL. 

 What if I don’t know what a particular acronym stands for? 
Check the Acronyms section of the Glossary (if it’s not there, search the document for it). Usually there are multiple instances 
of the acronym spelled out and sprinkled throughout the Guide. 

 In the event of conflicting information, which takes precedence: the Guide or the UI specification document/BID?  
The Guide catalogs generally applicable, predominant system-wide behaviors, properties and appearances. UI specs/BIDs, on 
the other hand, document exceptions and describe specific details that markedly differ from Guide specifications. BID 
descriptions trump those of the Guide. 
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1.2.3.5. Baselining the Guide 

 If this is a “living document” that changes fairly often, how can anyone ever keep up to date?  
The answer is baselining. Sections of the Guide get “locked” after an intensive stakeholder group review process. This 
ensures that those sections receive the official “stamp of approval” and should, theoretically, experience relatively few 
changes afterwards. As section after section is baselined, the Guide as a whole becomes a more stable and orderly reference 
document. 

 How does one know by looking at the Guide what has or hasn’t been baselined? 

Just as updated material is denoted by the  icon, recognize baselined material by the  symbol attached to the applicable 
first-, second- or third-level heading. The symbol automatically appears in the Table of Contents, so approved or “locked” 

material is easy to spot at a glance. The  icon shows line items that require baseline review. The entire Guide is currently 
under baseline review, except those sections marked with a  icon. 

1.2.3.6. Deferred Features 

 How does one tell if certain features described in this document pertain to Release 1 or a later release?  
In addition to features approved for Release 1 use, the Guide documents proposed features deferred to later versions of the 
software. Any such functionality slated for future inclusion/examination occurs in the Deferred Items section. 
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2.0. Development Specifications 

2.1. Main Application Window  

2.1.1. Title Bar  

 

 Figure 1: Browse Titlebar Example 

The main HECM window features the left-aligned application icon and the title “Horizon Enterprise Content Manager.” It also 
indicates the current tab selection in the following form: <Application Icon> + <Application Name> + <Em Dash (Unicode 2014)> + 
<Tab Name>. Text in the title bar is also contingent upon the user’s role, since the title reflects the active tab. If a tab does not, for 
some reason apply, the title bar reverts to its default state, as described in the first sentence above. While the title bar shows to only 
the tab level, the BCT shows the entire path to a specific folder, when dealing with content. 

Buttons in the title bar are Minimize, Restore/Maximize and Close; Help only occurs in dialog boxes.  

Present in Title Bar 
(Minimize, Restore or Maximize and Close) 

Absent from Title Bar 
(Help) 

        



  HECM User Interface Style and Standards Guide 

 

- 14 - 

© Copyright 2014 McKesson. Contents are confidential and proprietary. For internal use only. 

2.1.2. Window Properties 

2.1.2.1. Window Dimensions  

The HECM window at launch is always maximized (full screen). All panes assume their default allocations. The HECM application’s 
minimum resizable dimensions are 640 pixels x 480 pixels, principally to avoid odd rendering behavior in too-small window 
dimensions. The program is designed for display resolutions of 1024 pixels x 768 pixels and higher. 

2.1.2.2. Color Scheme   

As of the time of this writing, no official (custom) color themes exist. Standard .NET controls, which comprise the interface, inherit 
their look and feel from Microsoft Windows (in other words, themes are user-configurable at the operating system level, and the 
HECM application inherits those settings). Besides a considerable number of “Windows Classic” styles, XP ships with three “Windows 
XP” styles: Default (blue), Olive Green and Silver. The following table describes which HECM elements inherit settings from what 
system color member. 

 Review the following on a line item-by-line item basis, not by section.  

Name Description / Purpose Linked HECM Object(s) Status 

ActiveBorder  active window border color   

ActiveCaption  active window title bar background color   

ActiveCaptionText  active window title bar text color   

AppWorkspace  application workspace color   

ButtonFace  3-D element face color   

ButtonHighlight  3-D element highlight color   

ButtonShadow  3-D element shadow color   

Control  3-D element face color   

ControlDark  3-D element shadow color   

ControlDarkDark  3-D element dark shadow color   

ControlLight  3-D element light color   
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ControlLightLight  3-D element highlight color   

ControlText  3-D element text color   

Desktop  desktop color   

GradientActiveCaption  active window title bar lightest gradient color   

GradientInactiveCaption  
inactive window title bar lightest gradient 
color 

  

GrayText  dimmed text color   

Highlight  selected item background color   

HighlightText  selected item text color   

HotTrack  hot-tracked item color    

InactiveBorder  inactive window border color   

InactiveCaption  inactive window title bar background color    

InactiveCaptionText  inactive window title bar text color   

Info  tooltip background color   

InfoText  tooltip text color   

Menu  menu background color   

MenuBar  menu bar background color   

MenuHighlight  flat menu item highlight color   

MenuText  menu text color   

ScrollBar  scroll bar background color   

Window  window client area background color   

WindowFrame  window frame color   

WindowText  window client area text   

 

Source: MSDN (http://msdn2.microsoft.com/en-us/library/ system.drawing.systemcolors_members(VS.80).aspx). 

http://msdn2.microsoft.com/en-us/library/
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2.1.2.3. Status Bar  

The main application does have a status bar (unlike dialog boxes). However, it does NOT have any text in it. 

2.1.3. Resizing Behavior  

The resizing behavior described here is intended to minimize implementation time for Release 1. Expect this behavior to change in 
future versions, so that users with higher-resolution displays will get greater value from resizing the application. 

2.1.3.1. Toolbar 

When the user resizes the width of the display, anchor the buttons on the tool bar to the left-hand side of the application window. 
When the width of the line of tool bar buttons exceeds the width of the display, hide the tool bar buttons that extend beyond the 
width of the display on the right side. Restore these buttons when the user expands the application window wide enough to inc lude 
the previous hidden buttons. 

2.1.3.2. Left Side Pane (LSP) 

When the user resizes the height of the HECM application window to obscure LSP options and controls, display a vertical scroll bar 
anchored to the right side of the LSP to allow the user to scroll through the options. 

When the user resizes the width of the HECM application window, leave the vertical pane separator at the same distance from t he 
left side of the application window as before the resize. That is, when the user makes the width of the application window smaller, 
the LSP should remain the same width and the MCP and ODP areas should be smaller. When the user makes the width of the 
application window larger, the LSP should remain the same size and the width of the MCP and ODP should be larger. 

2.1.3.3. Object Details Pane (ODP) 

When the user resizes the height of the HECM application window, leave the horizontal pane separator at the same distance from 
the bottom side of the application window as before the resize. That is, when the user makes the height of the application window 
smaller, the ODP should remain the same height and the MCP area should be smaller. When the user makes the height of the 
application window larger, the ODP should remain the same size and the height of the MCP should be larger. 
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In the ODP, display the application buttons anchored to the lower, right-hand corner of the application window, offset as described 
in this document. If the user resizes the ODP to obscure any of the other controls, display vertical and horizontal scroll bars to allow 
full access to the controls. Do NOT allow the buttons to obscure other controls in the pane. 

2.1.3.4. Main Content Pane (MCP) 

In the MCP, display the application buttons anchored to the lower, right hand corner of the application pane, offset as described in 
this guide. If the user resizes the MCP such that any of the other controls are obscured, display vertical and horizontal scroll bars to 
allow full access to the controls. Do NOT allow the buttons to obscure other controls in the pane. 

2.1.4. Cascading Menu  

At the top of the main window interface (NOT in dialog boxes), a persistent cascading menu allows the user to drill down to specific 
operations. There are six (6) primary menus as follows: 

 

 Figure 2: Main Menu Bar 

Note: all selections in the following examples are shown in their enabled states. Some selections are mutually exclusive and/or 
module-dependent, so will never appear exactly as shown. Also, they are presented in the order they appear in the interface from 
left to right, not alphabetically. 
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2.1.4.1. Content Manager 

 

 Figure 3: Main Cascading Menu (Content Manager Menu) 

2.1.4.2. Workflow 
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 Figure 4: Main Cascading Menu (Workflow > Manage Worklists Menu) 

 

 

 Figure 5: Main Cascading Menu (Workflow > Manage Tasks Menu) 

 

 

 Figure 6: Main Cascading Menu (Workflow > Manage Content Menu) 
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2.1.4.3. Viewer 

 

 Figure 7: Main Cascading Menu (Viewer > Go to... > Page... Menu) 

 

 Figure 8: Main Cascading Menu (Viewer > Go to... > Document... Menu) 
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 Figure 9: Main Cascading Menu (Viewer > View > Fit Menu) 

 

 Figure 10: Main Cascading Menu (Viewer > View > Zoom Menu) 
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 Figure 11: Main Cascading Menu (Viewer > View > Rotate Menu) 
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 Figure 12: Main Cascading Menu (Viewer > View > Flip Menu) 

2.1.4.4. Report Manager 

 

 Figure 13: Main Cascading Menu (Report Manager > Run Admin Report Menu) 
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 Figure 14: Main Cascading Menu (Report Manager > Run User Report Menu) 

2.1.4.5. Administration 

 

 Figure 15: Main Cascading Menu (Admin > Configure > Security and Passwords Menu) 
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 Figure 16: Main Cascading Menu (Admin > Configure > Users, Groups, ACLs and Roles Menu) 

 

 Figure 17: Main Cascading Menu (Admin > Configure > Domain App Builder Menu) 
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 Figure 18: Main Cascading Menu (Admin > Monitor Menu) 

 

 Figure 19: Main Cascading Menu (Admin > User Settings Menu) 
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2.1.4.6. Help 

 

 Figure 20: Main Cascading Menu (Help Menu) 

For details on the Help icon on the far right of the menu bar, refer to Help. 

2.1.4.7. Font Attributes   

 

 Figure 21: Cascading Menu Font Attributes 

2.1.5. Button Bar/Toolbar  

The button bar occurs only in the main application menu, NOT in dialog boxes. Detailed button bar documentation occurs in 
individual User Interface Specification documents, while the images and a description of their properties occur in this document in 
the Button Bar/Toolbar Icons section. 

2.1.5.1. Drop Zone  

Information pending. 
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2.1.5.2. Content Bin  

Information pending. 

2.1.6. Breadcrumb Trail (BCT)  

The breadcrumb trail (BCT) originates above the Main Content Pane (MCP), just to the right of the tabs. It is left-aligned. The BCT’s 
behavior and presentation depend upon where the user is in the application (i.e., either a content- or operation-based tab/module). 
It occurs only in the main application menu, NOT in dialog boxes. The BCT at HECM launch shows the domain name only. If the user 
has access to multiple domains, the dropdown domain selector is present, showing by default the first domain in the list (it sorts 
alphabetically ascending by default). See the Operation-based Behavior description of the BCT for an example of each. 

2.1.6.1. Content-based Behavior 

The BCT serves as a reliable, quick-reference gauge of the user’s current location within a content directory structure. When working 
with content directly (e.g., when in Browse, Search or Viewer), the BCT starts with the domain root (preceded by the generic domain 
icon and labeled with the name of the domain itself) and proceeds down the directory tree to the user’s currently selected folder. 
Each tier of the path is clickable, which allows the user to jump from level to level as desired (provided that the user’s folder access 
rights allow it). File names do NOT appear at the end of this path, only the folder at the lowest level (i.e., the parent of a selected 
object). 

The BCT’s behavior is simple: it shows the lowest common denominator of all files in a set. In other words, it shows the path to the 
common parental folder to a group of files/folders as a whole, even if said commonality exists only at the top node (domain) level. 
This behavior is consistent when the user selects none, one or multiple line items. 

2.1.6.2. Operation-based Behavior 

The BCT shows the domain name/selector when NOT working with content directly. The generic domain icon precedes the domain 
label. If a user has access rights to multiple domains, the domain indicator displays as a dropdown in the BCT, from which the user 
can switch between domains at will. 

 

 Figure 22: Non-content, Single- and Multi-domain BCT 
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2.1.6.3. Inter-tab Dynamics 

If the user is in Search, for example, and clicks on a folder link in the BCT, the application takes the user to the Browse tab/module, 
highlights and expands the folder in the LSP, and displays the folder contents (including child folders) in the MCP. See also Sortable 
Columns for sorting rules. 

2.1.6.4. Long Path Truncation 

The contents of the BCT do NOT wrap. The BCT displays as much of the path that fits in the available space, adapting truncation in 
real time to dynamic window conditions (any resizing operation, folder changes, etc.). There is, however, a limit to how much 
horizontal space the BCT can claim for itself, regardless of whether the path itself is too long or HECM window resizing causes the 
situation. Either way, the OCD-1 can NOT be displaced, so the BCT must truncate itself after the domain name and folder indicator 
(>) with an ellipsis (…). The ellipsis replaces only as much of the path as is necessary, even if it means showing a partial folder name. 
The image below demonstrates this truncation schema. 

 

 Figure 23: Truncated Multi-Domain BCT 

When the mouse pointer hovers over any portion of the path, a tooltip displays the entire path. If the tooltip itself should be too 
long to display in one line, it wraps.  

2.1.6.5. Font Attributes 

 

 Figure 24: BCT Font Attributes 
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2.1.7. Object Count Display (OCD)  

2.1.7.1. Alignment and Behavior 

Right-aligned on the same line, horizontally opposite the BCT, the object count display (OCD) indicates the list view count for the 
current folder (or domain, whichever is applicable at the moment). Both folders and files add to the count, but only those that are 
“visible,” based upon the user’s security access rights. In other words, a folder may contain 20 items total (files and/or folders), but a 
restricted user may see only five of them. 

Conversely, for the same folder, a user with full rights will see all 20. The syntax and formatting for the OCD is: number in bold 
followed by the word “objects” in lower case, right-aligned. If there are no child objects, the OCD displays “0 objects.” See the Font 
Attributes  section for OCD font attributes. It occurs only in the main application window, NOT in dialog boxes. See Application 
Detailed View in The Three Panes section for an example in context. 

Space provision for three (3) digits, plus a six-pixel buffer on each side of the text, guarantees that the BCT length will never affect 
the OCD. 

 

 Figure 25: The BCT and OCD-1 

2.1.7.2. Font Attributes 

 

 Figure 26: OCD Font Attributes 

2.1.8. Navigation Tabs  

The main navigation tabs in HECM serve as single-click vectors to the primary modules of the application. For details of the proposed 
visibility feature, see Tab Row Persistence. At HECM launch, the user’s role dictates the initial active tab and what options exist in 
the cascading and right-click contextual menus. Standard users land on the Search tab/screen and see only Admin options regarding 
a few personal settings. Contextual menu options are also limited by the user’s access rights, as certain controls and menu i tems are 
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either disabled or absent. System administrators, on the other hand, land on the Admin tab/screen and enjoy a wider range of 
controls and permissions in addition to their own personal settings. For more information and an example, see Title Bar. 

Note: the following are presented in the order they appear in the interface from left to right, not alphabetically.  

2.1.8.1. Admin 

 

 Figure 27: Admin Tab 

Upon logon, if the user’s role is that of administrator, the default landing area is the Admin tab. For the system administrator, this 
tab has a dual role: it provides quick access to the system administrative module, where one can manage users, groups, ACLs, roles, 
worklists, reports, metadata, domains, folders, mail server configuration, content types and more; it also gives the means for the 
Administrator to manage personal user settings, such as auto logoff configuration and logs. For the standard user, this tab’s singular 
function is to give the means for personal user settings management, such as auto logoff and logs. Whereas system administrators 
land on the Admin tab upon logon, other users do NOT; they land on Search. 

2.1.8.2. Search 

 

 Figure 28: Search Tab 

The function of the Search tab is to jump immediately to the Search form, so that the user can personalize a search to locate  and 
retrieve specific content. The module complements Browse, while it offers more powerful means to sift (i.e., proactively "filter" 
expected results via specific criteria, such as name, creation date, version, type and other metadata and properties), locate  and sort  
files. Search is the default landing tab at logon for users without system administrator privileges. Also, see an example of the Search 
form. 

2.1.8.3. Browse 

 

 Figure 29: Browse Tab 
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The Browse tab allows the user to navigate through a familiar hierarchical directory tree to manage content. Considerably more 
basic in functionality than its Search counterpart, Browse works well for manipulating content routinely accessed from specific 
folders. It is well-suited for users that rely upon a formally defined folder structure rather than metadata to store and retrieve 
content. Also, see an example of the Browse screen. 

2.1.8.4. Workflow 

 

 Figure 30: Workflow Tab 

The Workflow tab delivers the user to a sophisticated “to do” list of tasks and their various assignments, statuses, deadlines and 
other tracking criteria. The module affords the ability to manage (e.g., add, delete, assign and reassign) worklists and tasks according 
to a logical and prescribed process. 

2.1.8.5. Viewer 

 

 Figure 31: Viewer Tab 

The Viewer tab/module allows the user to view content in a read-only environment. In this mode, the user can NOT permanently 
alter a system-resident file in any way, though zoom, rotate, flip, book view and other presentation options exist. The application 
natively supports a large number of popular formats. In the event that HECM can NOT internally handle rendering of a file, it hands 
off the task to another application. Content is NOT directly accessible in the Viewer tab; the user must first choose a piece of content 
from elsewhere in the system, such as in the Search or the Browse modules or in cases where content is linked to task. 

2.1.8.6. Reports 

 

 Figure 32: Reports Tab 
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For the system administrator, this tab has a dual role: it provides quick access to system audit, account maintenance and matrix 
reports; it also gives the means for the Administrator to manage personal user reports regarding content manager, content loa der 
and workflow. For the standard user (i.e., one lacking system administrative privileges), this tab’s singular function is to give the 
means for the same personal user reports mentioned above. 



  HECM User Interface Style and Standards Guide 

 

- 34 - 

© Copyright 2014 McKesson. Contents are confidential and proprietary. For internal use only. 

2.1.9. The Three Panes   

2.1.9.1. Overview 

As far as layout and appearance are concerned, the HECM application’s main interface exists within the framework of a common 
window. It borrows heavily from the typical left-hand navigation scheme so prevalent in the Web world and a number of popular 
Microsoft products, among them Windows Explorer, Outlook and Visio. 

Immediately noticeable, the standard cascading main menu and button toolbar combination stretches across the upper portion of 
the window. All common commands used throughout the application occur in the menus. Their enabled or disabled statuses depend 
upon what type of object is being viewed, what the user’s role is, where he or she is in the application and what security rights he or 
she enjoys. 

Nestled below the menus and the buttons are the main navigation tabs on the left and the breadcrumb trail and object count display 
on the right. These divide the user experience into logically separated components by function, and provide persistent contextual 
feedback on the user’s location and operations. 

Below, the three main components of the UI dominate the display; they are: 

 the collapsible Left Selection Pane (LSP), or “Left Pane” 

 the collapsible/expandable Main Content Pane (MCP), or “Main Pane,” and breadcrumb trail navigation assistant 
combination 

 the collapsible/expandable Object Details Pane (ODP), or “Details Pane,” which appears only when required 

All panes share some common features. In particular, all scroll vertically and horizontally when required to accommodate content. 
When scrollbars are not needed, they are simply not visible. 
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 Figure 33: HECM Pane Arrangement 
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 Figure 34: Application Detailed View 

Note: A column can NOT align different ways simultaneously. Sorting does NOT effect alignment at all. The above is meant to convey 
that there are three possible alignment choices for any given column, whereas most other elements of the UI have but one.  
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2.1.9.2. Expansion and Collapse 

The three panes in the HECM application are divided by two shared, resizable pane separators. The resize feature is zero-sum, 
meaning that the space one gains is at the expense of the other(s). The expand/collapse control sits in the center of each pane 
separator; arrows indicate which way a click will send the separators. 

The custom controls shown in these sections describing pane behavior are intended to appear in Release 1, but may be deferred  
depending upon resources available to Development. Development will employ default .NET controls, and should time allow later in 
the cycle, create the custom ones described here. 

2.1.9.3. Space Allocation 

 

 Figure 35: Default Pane Space Allocation 

Default pane widths are one-third of the available horizontal space (application left edge to right edge) for the LSP with the 
remaining two-thirds allocated to the MCP and/or ODP. Vertically, the LSP gets 100 percent, while the MCP takes two-thirds and the 
ODP one-third. Unless the user explicitly changes the pane separator placement(s), they remain in the same arrangement, regardless 
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of whether or not the user moves to another tab. Should the ODP “disappear” when it is not required, its “reappearance” will be in 
exactly the same spot as previously, whether it was system default or user-directed. The locations of the pane separators persist 
throughout a given session, but return to their defaults each time the user logs back on. Future releases of HECM could possibly 
track pane separator locations from session to session as part of a user’s configurable, personalized user settings/profile. This is , 
however, out of scope for Release 1. 

2.1.10. Left Select Pane (LSP)  

2.1.10.1. Overview 

The multi-purpose Left Select Pane (LSP) modifies, in most cases, the content of the main content pane (MCP). A variety of 
navigation and operation-oriented presentations can co-exist in the LSP. For example, one can run searches, browse or navigate 
throughout the system. In a typical case, the main navigation tabs represent the top-level area, while menu trees or 
collapsible/expandable categories within the tabs allow the user to drill down to logically grouped operations.  

LSP forms, when they exist, are “mini-forms.” To fit more effectively in the tight space, controls, labels and text are smaller versions, 
single column-stacked and packed more tightly than their larger, more liberally spaced brethren in the MCP. This minimizes the need 
for excessive scrolling. 

“Search” is an example of a form-driven, operations-oriented LSP function. Search criteria and parameters are selected in the LSP, 
while results appear in a grid list in the MCP. On the other hand, other actions—such as “Browse” and “Admin”—see the user merely 
selecting an operation from a collapsible/expandable category or navigating down a directory tree to reach a specific set of 
operations or a filtered result set. 

The contents of the LSP change based upon a variety of command vectors. The most obvious are the main navigation tabs located 
just above the LSP. These are, from left to right, Admin, Search, Browse, Workflow, Viewer and Reports. Other content changers are 
the cascading menu, the button bar and the breadcrumb trail. 

The LSP is collapsible to the left margin, where its control arrow changes direction (from left- to right-oriented) to indicate is 
expandability. 

2.1.10.2. Pane Resize Behavior 

For the LSP, clicking the control toggles between collapse to the left application window edge and expansion to the expanded 
setting. Of the three panes, the LSP is the simplest, because it does NOT automatically expand to the right edge with a click on the 
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control (this can be achieved manually, however, via a click-and-drag). There are only two states: collapsed left and expanded 
(default or user-defined), with the arrow on the control merely switching direction. The figure below shows the ODP present with 
the LSP in the (left-)collapsed state. 

 

 Figure 36: Default LSP/MCP Expanded State with Zoomed Control (ODP Absent) 
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 Figure 37: LSP in Collapsed State 

 

 Figure 38: LSP in Manually Expanded State 
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 Figure 39: Default MCP/ODP Heights with Collapsed LSP and Zoomed Controls 
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2.1.10.3. Font Attributes 

 

 Figure 40: LSP Font Attributes 

2.1.11. Main Content Pane (MCP)  

The Main Content Pane (MCP), as mentioned above, depends largely upon input from the LSP, and, secondarily, from other 
command vectors elsewhere. If the LSP presents the user with more general selection categories and operations, the MCP displays 
the specific. For example, a user can search for content via the LSP and then view the result set in the MCP. Upon selecting a list item 
in the MCP, the user can then view specific details of a given file, such as metadata, properties, comments and signatures. 
Furthermore, the user can elect to view or edit a file as desired. 

From Browse in the LSP, the user drills down through the directory tree from the domain level down to a specific. The behavior of 
the MCP in this case is virtually identical to that of Search. Workflow and Reports follow a similar method of perusing lists of 
worklists and report types in the LSP, to selecting and managing operations and reports in the MCP. When in Viewer mode, the 
native content viewer loads the read-only files one at a time into the MCP. Collapsing the LSP maximizes the view space in the MCP. 
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2.1.12. Object Details Pane (ODP)  

Located beneath the MCP, the Object Details Pane (ODP) represents the final level of increasingly specific data presentation to the 
user. In a typical scenario, the user first selects a tab, then an operation category and operations from the list in the LSP (for 
example, a search with particular criteria). The MCP populates with a list of objects and their high-level details. The user sorts and 
peruses the list, then selects a particular line item. The ODP then takes its cues from this selection and displays the detai led 
information and operations associated with the object in question. 

When the operation or information specificity display level does NOT require the ODP, the system removes it completely (i.e., it is 
NOT even shown in its collapsed state). In a multi-select situation, the ODP remains visible at the same position, but removes all 
content from itself. 

The MCP/ODP expansion and contraction behavior is similar to that of the LSP, but with three distinct states: collapsed down (MCP 
maximized vertically), expanded (default or user-defined, in which the MCP and ODP in some fashion divide up the window’s vertical 
space) and collapsed up (ODP maximized vertically). The figure below demonstrates the ODP in the collapsed-down state. 
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 Figure 41: Default LSP Expanded State and Collapsed ODP with Zoomed Controls 



  HECM User Interface Style and Standards Guide 

 

- 45 - 

© Copyright 2014 McKesson. Contents are confidential and proprietary. For internal use only. 

The example below demonstrates the system default expanded view. Notice the bi-directional control on the MCP-ODP separator. 
As expected, a click on the down arrow control collapses the ODP down, maximizing the MCP vertical space. Likewise, a click on the 
up arrow collapses the MCP up, maximizing the ODP vertical space. 

 

 Figure 42: Default LSP/MCP/ODP Expanded States with Zoomed Controls 
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In this final example, the entire window area is devoted to the ODP. Generally speaking, this is probably not the most judicious use 
of screen real estate, but the user can elect to do this, nonetheless. In some cases, this may be a useful configuration, especially, for 
example, if the Details Pane contains a lot of metadata or other information that would otherwise require excessive horizontal 
and/or horizontal scrolling. 

Note that in both the collapse-up and collapse-down scenarios, the double direction control becomes a single one, which points 
back to the one direction it can go. In both cases, subsequent clicks in the same direction cycle through one collapsed state, through 
the (default or user-defined) expanded state to the other collapsed state. 

 

 Figure 43: LSP Collapsed, MCP Collapsed and ODP Expanded with Zoomed Controls 
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2.2. Dialog Boxes  

2.2.1. Relationship with Parent  

Dialog boxes appear horizontally and vertically centered atop the triggering shell display (that is, the HECM main window, not 
necessarily the center of the monitor, unless HECM is maximized). That is to say, the parent window is never blank; instead, it 
contains the fully rendered display the user had just seen prior to the pop-up launch. The only exception to this rule regards auto 
logoff, in which case the user sees a “stripped” version of the main application window. 

Users often use buttons to launch dialog boxes to complete a specific operation, such as looking up and selecting users, groups, 
content, etc. Such button labels are verbs that describe the operation followed by an ellipse (…). The ellipse cues the user that the 
operation continues in a popup window, not the main application window. An example would be “Reassign…,” which launches a 
dialog box, whereas “Own” occurs in the parent window. 

Likewise, if the operation is known to consistently launch an external editor/viewer application or leverages some inherent Windows 
functionality—such as a “Browse Folder” dialog—it is appropriate to use the ellipse in such cases as well. However, in the event that 
an action switches the interface to another section within the same window—for instance, a different tab in the ODP—do NOT use 
the ellipses after the verb. 
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2.2.2. Pop-up Anatomy 

2.2.2.1. Window Dimensions 

 

 Figure 44: Standard Dialog Box 

Maximum typical dimensions are 500 pixels wide x 600 pixels high, though there are a few exceptions to this rule. Use scrollbars, but 
only if absolutely necessary. See actual-sized example image below. The standard dialog box’s dimensions are fixed at 450 pixels 
wide x 170 pixels high. 
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 Figure 45: Jumbo Dialog Box with Form 
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2.2.2.2. Title Bar 

For the sake of consistency in informing the user of where they are and what the consequences are of their actions, dialog window 
titles take on the verbiage of the trigger that spawned them; thus, a button that reads “Add Content” results in a dialog box with an 
“Add Content” title. A “Reset Password” dialog will have assumed the namesake of its corresponding cascading menu selection. Both 
the icon and the “Horizon Enterprise Content Manager” text are absent from pop-ups. 

Note that title bar specifications for dialog boxes differ from those of the main window. See also status bar. 

Present in Title Bar 
(help and close) 

Absent from Title Bar 
(minimize, maximize and restore) 

Button(s) 
(usually just “OK”) 

     
OK

 

2.2.2.3. Modality and Resizing 

All dialog boxes in HECM are modal, except for Help. Help is not modal by design, so that the user can continue to simultaneously 
work in HECM and reference the Help window at will. Modality is application-level, not system. Dialogs do NOT resize in any fashion. 

2.2.2.4. Status Bar 

Dialog boxes do NOT have status bars. 
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2.2.2.5. Font Properties 

 

 Figure 46: Dialog Box Font Attributes 

2.3. Forms 

2.3.1. Layout  

In general, form elements are stacked vertically in a form. This is particularly true of forms in the LSP and in pop-up dialog boxes. In 
the MCP, ODP and in jumbo dialogs, form elements may display in two columns. Think of a form element as comprised of four parts:  

 required field indicator, when applicable 

 form element text label 

 the (enabled or disabled) form element itself 

 post-validation tooltip-equipped error icon, when applicable 
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Often data or operations logically group together on the same screen and in close proximity. For example, add, delete, view a nd 
rename operations can fall under the common label “Manage.” Likewise, data like street, city, state and zip code can be said to fall 
under the category “Address Information.” Be constantly alert to these logical conglomerations, as they make the user interface 
more intuitive, easier to use and orderly. 

2.3.2. Common Elements   

HECM uses a number of form elements users recognize from the Windows operating system and browser-based applications. See 
also Field Labels. Note: appearance will vary between operating systems; examples are from Windows XP Service Pack 2. 

2.3.2.1. Labels  

All labels sit right-aligned to the left of form elements. Labels next to (radio buttons and checkboxes) are also clickable. A colon (:) 
does NOT follow any label. Labels do NOT wrap, except in extreme circumstances when severe space limitations so dictate. 

2.3.2.2. Sortable Columns  

Tables are always sortable by column header, unless otherwise specified. A subsequent mouse-click on a column header reverses 
the previous sort. Tables are default sorted by the first column in ascending order, unless otherwise specified. 

Clicking a different column to sort triggers an ascending order sort. Click the same column a second time to descend-sort. Sorting is 
case-insensitive (i.e., a=A). Ascending sorts have an upward-pointing triangle, while descending have a downward-pointing triangle. 

Null or blank values are treated as the first items in an array sorted in ascending order. See sort order for column values, below. 

Sort Type Alphabetical Numerical Alphanumerical Dates Directories Checkboxes 

 

Low → High 
(e.g., null, a, b, c…) 

Low → High 
(e.g., null, 1, 2, 3…) 

Low → High 
(e.g., null, 1, 2, 3, a, b, c…) 

Earlier → Later 
(e.g., null, Jan. 1, Feb. 1, Mar. 1…) 

Folders → Files 
Low → High 

 →  

 

Low ← High 
(e.g., c, b, a, null…) 

Low ← High 
(e.g., 3, 2, 1, null…) 

Low ← High 
(e.g., c, b, a, 3, 2, 1, null…) 

Earlier ← Later 
(e.g., Mar. 1, Feb. 1, Jan. 1, null…) 

Folders ← Files 
Low ← High 

 ←  

      

Note: Checkboxes take primary sort when their headers are clicked, then the next column (e.g., “Name”) takes secondary sort. 

The following example shows an alphabetical, ascending sort of some fictitious files.  
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 Figure 47: Column Header Sorting 

2.3.2.3. Text Fields  

Standard Size 

 Width: 200 px fixed 

 Height: one 20-px-high row (including 1-px border) 

 Max Characters: 80 

 Wraps: No 

Intermediate Size 

 Width: 500 px fixed 

 Height: one 20-px-high row (including 1-px border) 

 Max Characters: 250 

 Wraps: Yes 

Jumbo Size 

 Width: 500 px fixed 
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 Height: three 20-px-high rows (including 1-px border) 

 Max Characters: 500 

 Wraps: Yes 
 
Hybrid Size 

 Width: 200 px fixed 

 Height: three 20-px-high rows (including 1-px border) 

 Max Characters: 250 

 Wraps: Yes 

 

 Figure 48: Standard Text Fields (Error, Active and Inactive) 

Use text fields to collect free-form user text input and secondarily to display pre-populated text. They are blank by default, unless 
otherwise specified. Wrapping applies to jumbo-sized fields only. Employ such fields sparingly. For example, “Comment” and 
“Description” fields implicitly call for longer text strings than, say, “First Name.” In the MCP and ODP where two columns of 
elements are common, span long fields across the columns (so that they do not dictate column width). Examples are for comments 
or descriptions, which require more space). For more information on colors and fonts attributes associated with text fields, see 
Messaging and Fonts. 

Note: In the LSP where space is limited, use the hybrid field instead of jumbo. 

2.3.2.4. Dropdowns  

Standard Size 

 Width: variable, dictated by content (no fixed size) 

 Height: one 20-px-high row (including 1-px border) 

 Max Characters: N/A 

 Wraps: No 
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 Figure 49: Dropdowns 

Primarily used for selecting a single value from two or more that must be explicitly spelled out (for simple toggles—a simple binary 
choice—single checkboxes, checked or unchecked, are usually more useful and real estate-efficient). The default initial value is 
“Select…” or “Select <item>…”, unless otherwise specified. In the absence of other instructions, values should be shown in 
alphabetical order. Length of the element is only as long as the contained text (i.e., no fixed width).  

2.3.2.5. Checkboxes  

Standard Size: .NET default 

 

 Figure 50: Checkboxes 

Checkboxes are binary switches: they toggle a single item on and off. By default, checkboxes are blank (unchecked), unless 
otherwise specified. Dimensions are Windows standard. Checkboxes are center-aligned in columns, when used. However, HECM 
does not use Checkboxes to select tabular data. Clicking the box itself or the label toggles the checkbox if it is enabled. For checkbox 
sorting details in grids, refer to the table in the Sortable Columns section. 

2.3.2.6. Radio Buttons  

Standard Size: .NET default 
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 Figure 51: Radio Buttons 

Radio buttons are also binary switches when used in pairs. When three or more are used in conjunction, they present the user with 
mutually exclusive selection options (i.e., only one can be chosen at a time). By default, radio buttons are blank, unless a default 
selection is otherwise specified. Radio buttons align left with other form elements, but generally labels do NOT accompany them to 
their left. A group of radio buttons extends out horizontally on the same line, as they are NOT stacked vertically (unless there is need 
to wrap, which should be a rare occurrence). For an example of a horizontal group and its affect on tab order, see Tab Key and Tab 
Order. 

2.3.2.7. Spinner Controls   

Standard Size 

 Width: variable, dictated by content (no fixed size) 

 Height: one 20-px-high row (including 1-px border) 

 Max Characters: N/A 

 Wraps: No 

 

 Figure 52: Spinner Controls 

Spinners are a convenient way to increment or decrement a selection. The user may left-click on the arrow buttons or use the 
vertical arrow keys (Up is next, Down is previous). The horizontal arrow keys transfer selection left and right to jump from item to 
item (in the example above, between hours, minutes and seconds. As of this writing, the only example of a spinner control in HECM 
is the Time Picker. 

2.3.2.8. Mover Boxes  

Standard Size: Variable, depending upon pane and case-by-case use (no fixed size) 
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 Figure 53: Mover Boxes 

Mover boxes are used to transfer list items back and forth between two text areas. By default, usually one is blank and the other is 
populated. HECM mover boxes have grids to clarify the line item through descriptions, comments and/or other cues.  

2.3.2.9. Buttons  

Standard (Minimum) Size: 69 pixels wide and 21 pixels high; variable to accommodate content, as required* 

All buttons must comply with the minimal size directive, even those with very short text on them, such as “OK.” 
Exceptions are specialty buttons, such as title and toolbar, look-up, mover buttons and the like. 

*If button text exceeds the standard 69 pixels wide, the text plus its six-pixel buffer dictate button size. See below for illustration. 

 

 Figure 54: How to Determine Long Button Size 

Buttons that are not (yet) usable at a certain point in an operation are visible, but disabled. If, based on a user selection , a button 
becomes relevant to the operation (for instance, the user enters all required information into a given form), the button becomes 
enabled. The user may then proceed. For more information, see Enabled, Disabled or Absent? 

Text on buttons use verbs in the imperative and often a noun object for clarification. For example, “Apply Settings” or “Add” is more 
immediately descriptive and useful at a glance than a vague “OK,” which, by itself, doesn’t tell the user what the button explicitly 
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does. 

Also, word choice for a given button/action must remain constant throughout the application. For instance, although “Add,” “New” 
or “Create” may all be equally valid choices for a certain operations, one must pick one and consistently use it. For this reason, the 
following table is maintained to keep track of whether the same button with the same function elsewhere in the application reads, 
say, “Quit,” “End” or “Finish” instead of “Close.” 

Button Description / Purpose Status 

...
 

Launches a look-up dialog.   

<
 

<<
 

Transfer Left (all items and single item, respectively); used in mover boxes.  

>
 

>>
 

Transfer Right (single item and all items, respectively); used in mover boxes.  

Apply Settings
 

Saves and immediately applies any changes made to a (usually admin) form.  

Cancel
 

Quits the current operation without saving changes (if applicable), but does not exit application.  

Change Password
 

Provides functionality to change a password.  

Close
 

Closes and cancels the operation. It returns to a “default” operation specifically defined for that operation area.  

Continue
 

Used for intermediate steps in a multi-screen operation.  

Create
 

Triggers the operation that enables the non-admin user to add a new item.  

Delete
 

Deletes the active record shown in the displayed form.  

Exit
 

Closes all open windows and exits the application to the OS desktop.  

Generate
 

Instructs the application to generate some value, for example, a temporary password.  

Log Off
 

Logs user off of application, but does not quit the application.  
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New
 

Triggers the operation that enables the admin user to add a new item.  

OK
 

Used in dialogs when the user has nothing to do but acknowledge the box to dismiss it.   

Refresh
 

Refreshes the view (field values, grid data, etc.) of a form by asking the server for the most recent data. Used primarily in 
operations where a list needs to be refreshed from the server more frequently than upon form submission, or when the 
user wishes to verify visually the addition of new data in a record or a file to the system. 

 

Reset
 

Clears all user-entered data and resets a form to its default state.  

Resubmit
 

See Submit.   

Retry
 

Closes a dialog, so the user can return to a given task and try again.   

Save
 

Generic button for general use across the application to save changes and finish a particular operation.  

Save Settings
 

Saves any changes made to a (usually admin) form.  

Search
 

Clicked after a user enters parameters to run a search.  

Select
 

Indicates selection of a line item in a grid.  

Skip
 

Allows the user to decline a system prompt to undertake some optional operation.  

Submit
 

Submits and saves data, but does NOT close an operation. Form remains populated and the record remains active in the 
form until the user clicks [Close] or [New], or selects a different item to edit.  

Unlock Account
 

Provides functionality to unlock a locked account.  

 

2.3.2.10. Grids    

Grid sizes, resizing behavior and properties follow .NET defaults. 
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Following .NET standards, if the length of the data in a row cell exceeds the amount of space for the column the name will be 
truncated and will end in “…”.  If a user hovers over the data, the tooltip will display the data in its entirety. Neither the “…” nor the 
tooltip apply to a grid column header. 

2.3.3. Spacing, Placement and Alignment  

2.3.3.1. Horizontal Alignment 

Alignment Description / Details 

 Left Numerical grid data 

 Left All form elements (text fields, dropdowns, checkboxes, radio buttons, etc.) 

 Left Most non-numeric text in tables, whether in fields or in cells 

 Left Breadcrumb trail 

 Left Text in the LSP, including banners 

 Left Menu items 

 Left Buttons on the button bar 

 Center Dates and date ranges in tables 

 Center Tab labels (both active and inactive) 

 Center Text and icons on buttons                                                                       

 Right Field labels 

 Right Control buttons themselves 

 Right Object count display 
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2.3.3.2. In Dialog Boxes 

 

 Figure 55: Form Element Spacing in Dialogs 

2.3.3.3. In Panes 

Form elements in the LSP stack in a single column. Occasionally, related elements may occupy a single row, but this is the exception 
rather than the rule. The maximum MCP and ODP column count is two. A form’s “master buttons” always appear in the same place 
in each pane: right-aligned at the bottom edge, regardless of how many or few elements populate the form. These buttons occur 
outside any scrollable areas. If a pane must scroll its content, the master buttons remain persistently visible and fixed. 
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 Figure 56: Form Element Placement within Panes 

Pane content does NOT necessarily have a double gutter as dialog boxes do. In cases where no inner bounding box exists, a single 
15-pixel “buffer” pushes all vertical and horizontal content away from the inner edge of the frame. Otherwise, all relative posi tioning 
of elements is exactly the same as in dialogs, with the exception that ODP and MCP forms can sometimes consist of two columns. 
Separate these columns by at least 20 pixels. Treat tabs in the ODP in precisely the same manner as the inner bounding boxes of 
dialog boxes (i.e., 30 pixels of total padding between the inner window edge and content.  
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 Figure 57: Form Element Spacing in Panes 

2.3.4. Special Considerations  

2.3.4.1. Date Picker 

 
 Figure 58: Date Picker 

HECM uses a calendar control developed in-house. It offers additional customization options over the default .NET one. Specifically, 
it initially displays no date and reads “Select date…,” as required by, for example, Search. It accepts manual input or use of a 
dropdown-navigable calendar to choose a specific date. 

Manual Input 

The user can NOT directly type in a date. Instead, the user must open the control and choose  
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2.3.4.2. Time Picker 

 

 Figure 59: Time Picker 

HECM uses the standard Microsoft .NET clock control. It uses a spinner control to increment or decrement hours, minutes and 
seconds. The user may optionally jump between the three using horizontal arrow keys, and increase or decrease numbers using the 
vertical arrow keys. The time picker inherits its format (e.g., a 12- or 24- hour display) from the operating system’s regional and 
language settings. 

2.3.4.3. Required Fields  

Occasionally, the user must address certain form elements in order to proceed with a given HECM operation. For example, user 
name and password fields are mandatory in order for the user to log on to the system. The “Required Field” marker appears in any 
pane that houses mandatory form elements. It is not uncommon for all panes to simultaneously display the marker. The marker 
image has the “required” text included in the image itself; no additional text is necessary. 

 

 Figure 60: Required Field Indicator Key 

The icon in the marker aligns vertically with the required icons ( ) next to each field in the first column (see the vertical arrow shown 
in the image below). The marker simultaneously aligns horizontally with the center of the main buttons in the pane (see the 
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horizontal arrow shown in the image below). 

 

 Figure 61: Required Field Marker Alignment 

Note: In addition to any other existing validation rules, “Space” and “Tab” key entry in required fields is invalid and will generate an 
error. 

2.3.4.4. Enabled, Disabled or Absent? 

What manner of alchemy or voodoo explains when a given control—be it a button, menu option, tab or other element—is visible or 
invisible, enabled or disabled? The answers to a few questions make it clear: 

 Absent – Does the user possess sufficient security rights to view it? For example, a regular user will never see a strictly Admin-
level control, because it is absent from the application altogether. As a general rule, if the user will NEVER have an opportunity 
under any circumstances to use a given element, remove it from the interface. 

 Disabled – Have all logical preconditions for a certain action been fulfilled? For instance, assuming a user has the appropriate 
access commands, a “Delete” menu option will activate only when in a content management-oriented module (such as Search 
or Browse) and the user selects a file or folder to manage. Until an object is selected, the “Delete” command remains disabled 
(i.e., visible, but inactive). Even if a user RARELY has an opportunity (even under a single set of circumstances) to use a given 
element, include it in the interface. 

 Enabled – Whereas security rights and preconditions dictate the appearance and functionality of many elements, others are 
perpetually enabled, because they ALWAYS meet all of the aforementioned criteria. For example, the options in Help are 
available to any user at any time, without regard to contingencies or security levels. Users can elect to cancel an operation, 
jump between tabs or cascading menus or exit the system at any time. 

2.3.4.5. File Size   

Content file size will be displayed to the user following the below rules: 
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 Show and round values out to no more than two decimal places, as appropriate. 

 If value is a whole number (all values after the decimal are zero), no decimal is necessary.  

 If hundredths digit (the second one after the decimal) is zero, show only to tenths (just the first one after the decimal).  

 If the value of the tenths digit is zero, but that of the rounded hundredths is 1 – 9, show to hundredths (both digits after the 
decimal). 

 RIGHT: 1 MB, 2.5 KB, 5.05 TB 

 WRONG: 1.00 MB, 2.50 KB or 5.0 TB 

Range Display Format Abbreviated? Notes 

0 bytes – 999.99 bytes bytes No Use entire lowercase word 

1 KB – 999.99 KB KB Yes Stands for “kilobytes”; use uppercase 

1 MB – 999.99 MB MB Yes Stands for “megabytes”; use uppercase 

1 GB – 999.99 GB GB Yes Stands for “gigabytes”; use uppercase 

1 TB – 999.9 TB TB Yes Stands for “terabytes”; use uppercase 

 

2.4. Mouse and Keyboard Input  

2.4.1. Mouse 

2.4.1.1. Left Click 

 

Left mouse clicks select rows in grids, activate controls and place focus on fields, folders and files, as applicable. 
Sustained left mouse clicks provide drag-and-drop capability. Shift+ click allows selection of multiple rows in lists of 
content and/or folders. 
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2.4.1.2. Right Click 

 

Right mouse clicks give rise to contextual menus for specific relevant operations to a given module in accordance with 
rules regarding content manipulation, the user’s permissions, etc. These menus include icons and disabled options for 
unavailable selections, just as the cascading menu does. 

2.4.1.3. Double (Left) Click 

 
Double mouse clicks launch the Viewer module for (read-only) viewing of content. 

2.4.1.4. Pane Resizing 

When the user places the mouse pointer—be it the arrow pointer or text selector, for example—on the vertical pane separator, the 
pointer changes to a horizontal resizer. In the case of the horizontal pane separator, the pointer changes to a vertical resizer. The 
user then clicks and drags to the desired position. On the pane control itself, the user sees the arrow pointer, which indicates a 
clickable action. A single-click on the control expands or collapses, as applicable, according to the direction the control arrow 
indicates. The controls themselves on the pane separators are non-standard. 

 

 Figure 62: Mouse Pointer Reference 

2.4.2. Keyboard 

Physical impairment, environmental factors, hardware availability and maintenance and a host of other variables affect the user’s 
input device options. As a matter of principle, the UI team recognizes the importance of keyboard-only access to every facet of the 
application. Although initial release does NOT attain an analogous level of utility and navigability to mouse input, future HECM 
versions will.  

Please note that the following is NOT a comprehensive account of all supported Windows standard hotkeys and key combinations, 
just those deemed most relevant for the majority of key HECM operations. 
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2.4.2.1. Menu Hotkeys 

Each cascading menu patriarch accepts keyboard input to receive focus and highlight the first selection, as denoted by the 
underlined letter. 

 

 Figure 63: Main Cascading Menu (Keyboard Access) 

Second- and third-level cascading menu selections also accept keyboard navigation. Once the user chooses a menu, a subsequent 
letter key press—corresponding to one of the underlined letters in the menu options—shifts selection to that item. Note that the 
letter assignments per menu must be unique, but the same letter may be used in any or all menus without adverse consequences, 
since no more than one cascading menu can ever be activated and in use at the same time. 

2.4.2.2. Function Keys 

 
 Figure 64: F1 Key 

Windows Default:   Displays help. 
HECM Application:  Launches universal HECM help. 
States Toggle:     No. 

 
 Figure 65: F5 Key 

Windows Default:   Updates (refreshes) the active window. 
HECM Application:  Refreshes view. 
States Toggle:     No. 

 
 Figure 66: F8 Key 

Windows Default:   None. 
HECM Application:  Exits the HECM application to desktop. 
States Toggle:     No. 
Notes:          Equivalent to Windows’ ALT+F4, which is also supported. 



  HECM User Interface Style and Standards Guide 

 

- 69 - 

© Copyright 2014 McKesson. Contents are confidential and proprietary. For internal use only. 

 
 Figure 67: F10 Key 

Windows Default:   Activates the menu bar in the active program. 
HECM Application:  Activates the Content Management menu bar. 
States Toggle:     Yes. 

 
 Figure 68: F12 Key 

Windows Default:   Shows/hides the toolbar in Internet Explorer. 
HECM Application:  Shows/hides the toolbar in Viewer. 
States Toggle:     Yes. 

2.4.2.3. Tab Key and Tab Order 

Specifying a tab order allows users to access items in a logical order. Otherwise, applications generally present the sequence in the 
order it appears in the source code, which may appear haphazard and difficult to understand. Unless otherwise specified, tab order 
logically progresses line by line from top to bottom, left to right. From a pane perspective, this equates to the following order: LSP → 
MCP → ODP. 

 
 Figure 69: Tab Key 

Menus: Cycles vertically through menu selections or horizontally to a child menu. 
Fields:  Jumps between editable elements in a predetermined order dictated by the tab index. 
Trees:  Shifts focus from tree to next editable element, but retains selected directory. 
Grids:  Moves focus from grid to next editable element outside the grid. 
Notes:  The Shift+Tab key combination reverses the direction of the above actions. 

A few notable rules regarding tab order in forms follow: 

 Error conditions do NOT alter tab order (in other words, tab order remains the same whether field data is erroneous or not).  

 Tabbing entirely skips field labels, LSP banner titles and other text, plus “Required Field,” error and other images and disabled 
form elements, such as read-only fields. 

 In two-column scenarios (such as that shown in the image below), the left column completes first row-by-row, then jumps to 
the top of the right column and proceeds in like manner to the end of the form (consider jumbo fields part of the left column, 

though they span). 
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 Figure 70: Form Tab Order Example 

Note: spacing is not to scale in the above image to more easily illustrate tab order. 
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2.4.2.4. Other Keys 

 
 Figure 71: U/D Arrow Keys 

Menus: Cycle vertically through menu selections in the active menu. 
Fields:  Expands dropdowns; shifts a row up/down in list boxes, text areas, dropdowns, etc.  
Trees:  Up selects previous shown item (above); Down selects next shown item (below). 
Grids:  Jumps between editable elements in a column; moves selection one row. 
Notes:  In a radio button group, Up selects previous, Down selects next 

 
 Figure 72: L/R Arrow Keys 

Menus: Cycle between top-level menus; expands menus and selects top-most option in each. 
Fields:  Moves the cursor through text one character forward or backward at a time. 
Trees:  Left collapses folders; Right expands folders. 
Grids:  Jumps between editable elements in a row. 
Notes:  In a radio button group, Left selects previous, Right selects next 

 
 Figure 73: Spacebar 

Menus: No effect. 
Fields:  Selects/deselects checkboxes. 
Trees:  No effect. 
Grids:  No effect. 

 
 Figure 74: Delete Key 

Menus: No effect. 
Fields:  Deletes selected contents of a field, but NOT the field itself. 
Trees:  Deletes objects, if the user has sufficient rights, and no system dependencies exist. 
Grids:  Deletes objects, if the user has sufficient rights, and no system dependencies exist.  

 
 Figure 75: Shift+Click 

Menus: No effect. 
Fields:  No effect. 
Trees:  Select multiple adjacent objects, if the user has sufficient rights and module supports.  
Grids:  Select multiple adjacent objects, if the user has sufficient rights and module supports.  
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 Figure 76: Control+Click 

Menus: No effect. 
Fields:  No effect. 
Trees:  Select multiple objects, if the user has sufficient rights and module supports. 
Grids:  Select multiple objects, if the user has sufficient rights and module supports. 

2.5. Images 

2.5.1. Library 

All images reside in StarTeam for interested parties and Development personnel alike. They share a naming convention and remain 
consistent with the file names listed in this document. 

 Location: StarTeam: eig\HECM\doc\ProductMgt\User Interface\R1.0\Image Library 

 Hyperlink: Image Library: 
starteam://starteamapp.mckesson.com:49260/158;ns=Project;scheme=id/580;ns=View;scheme=id/6708921;ns=Folder;schem
e=id;scope=full/ 

Below is the current list of images used in HECM. Icons with active and inactive states (mostly applicable to the main cascading 
menu) following the naming convention that active and inactive names are the same except for their suffixes, “-a” and “-i,” 
respectively. For example, the active state for “open” is “open-a” and the inactive state is “open-i.” 

 Review the following on a line item-by-line item basis, not by section. 

2.5.1.1. Cascading Menu and LSP Banner Icons 

Active Inactive File Name Dimensions Format Description In Library Status 

  addfile 16 x 16 PNG Add File icon in Content Manager and Viewer menus.   

  addurl 16 x 16 PNG Add URL icon Content Manager menu.   

  lspadmin 16 x 16 PNG Admin LSP banner icon.   

  lspbrowse 16 x 16 PNG Browse LSP banner icon and Browse icon in Content Management menu.   

  lspreports 16 x 16 PNG Report Manager LSP banner icon.   

starteam://starteamapp.mckesson.com:49260/158;ns=Project;scheme=id/580;ns=View;scheme=id/6708921;ns=Folder;scheme=id;scope=full/
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  lspsearch 16 x 16 PNG Search LSP banner icon.   

  lspviewer 16 x 16 PNG Viewer LSP banner icon.   

  lspworkflow 16 x 16 PNG Workflow LSP banner icon.   

  checkin 16 x 16 PNG Check In icon in Content Manager menu.   

  checkout 16 x 16 PNG Check Out icon in Content Manager menu.   

  checkundo 16 x 16 PNG Undo Checkout icon in Content Manager menu.   

  comments 16 x 16 PNG View Comments icon in Content Manager menu.   

  configure 16 x 16 PNG Admin > Configure menu and Admin LSP banner icon.   

  content 16 x 16 PNG Manage Content icon in Admin > Monitor and Workflow menus.    

  contentlink 16 x 16 PNG Manage Content > Link icon for the Workflow menu.   

  contentloader 16 x 16 PNG User Reports > Content Loader menus.   

  contenttypes 16 x 16 PNG Configure Content Types in Admin > Configure > Domain App Builder menu.   

  contentunlink 16 x 16 PNG Manage Content > Unlink icon for the Workflow menu.   

  delete 16 x 16 PNG Delete icon in Content Manager and Workflow menus.   

  docgoto 16 x 16 PNG Go to… document icon in Viewer menu.   

  docnext 16 x 16 PNG Go to next document icon in Viewer menu.   

  docprev 16 x 16 PNG Go to previous document icon in Viewer menu.   

  domainappbldr 16 x 16 PNG Domain App Builder in Admin > Configure menu.   

  domainfields 16 x 16 PNG Configure Metadata Fields in Admin > Configure > Domain App Builder menu.   

  domainfolders 16 x 16 PNG Configure Folders icon in Admin > Configure > Domain App Builder menu.   

  domains 16 x 16 PNG Configure Domains in Admin > Configure > Domain App Builder menu.   

  domaintemplates 16 x 16 PNG 
Configure Metadata Templates in Admin > Configure > Domain App Builder 
menu. 

  

  edit 16 x 16 PNG Edit icon in Content Manager and Viewer menus.   

  email 16 x 16 PNG Email Report icon in Report Manager menu.   

  exit 16 x 16 PNG Exit icon in Content Manager and Viewer menus.   

  find 16 x 16 PNG Edit > Find icon in Viewer and Report Manager menus.   
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  font 16 x 16 PNG Set Font in Viewer menu.   

  goto 16 x 16 PNG Edit > Go to icon for the Viewer menu.   

  help 16 x 16 PNG HECM Help in Help menu.   

  helpabout 16 x 16 PNG About HECM icon in Help menu.   

  helpsupport 16 x 16 PNG Support icon in Help menu.   

  helpupdate 16 x 16 PNG Updates icon in Help menu.   

  logoff 16 x 16 PNG View Signatures icon in Content Manager menu.   

  logoffauto 16 x 16 PNG Admin > User Settings > Configure Auto logoff menu.   

  log 16 x 16 PNG Admin > Log menu   

  logsconfig 16 x 16 PNG Configure Logs icon in Administration menu.   

  mailserver 16 x 16 PNG Admin > Configure > Mail Server   

  metadata 16 x 16 PNG View Metadata icon in Content Manager menu.   

  monitor 16 x 16 PNG Admin > Monitor menu   

  new 16 x 16 PNG New… icon in Content Manager and Workflow menus.   

  open 16 x 16 PNG File Open icon in Content Manager and Workflow menus.   

  pagefirst 16 x 16 PNG Go to first page icon in Viewer menu.   

  pagegoto 16 x 16 PNG Go to… page icon in Viewer menu.   

  pagelast 16 x 16 PNG Go to last page icon in Viewer menu.   

  pagenext 16 x 16 PNG Go to next page icon in Viewer menu.   

  pageprev 16 x 16 PNG Go to previous page icon in Viewer menu.   

  print 16 x 16 PNG 
Workflow > Manage Tasks/Worklists > Print/Report Manager > Print Report 
menus. 

  

  printlocal 16 x 16 PNG File > Local Print icon in Viewer menu.   

  printpreview 16 x 16 PNG File > Print Preview icon in Report Manager and Viewer menus.   

  properties 16 x 16 PNG View Properties icon in Content Manager menu.   

  pwdreset 16 x 16 PNG Reset Password icon in Admin > Configure menu.   

  pwdpolicies 16 x 16 PNG Password Policies icon in Admin > Configure > Security and Passwords menu.   
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  reportadmin 16 x 16 PNG Run Admin Reports icon in Report Manager menu.   

  reportaudit 16 x 16 PNG Run Admin Reports > Audit Report icon in Report Manager menu.   

  reportugrm 16 x 16 PNG Run Admin Reports  > Users, Groups & Roles Matrix Report menu.   

  reportuser 16 x 16 PNG Run User Reports icon in Report Manager menu.   

  reportuam 16 x 16 PNG Run Admin Reports > User Account Maintenance Report menu   

  security 16 x 16 PNG Security and Passwords icon in Admin > Configure menu.   

  signature 16 x 16 PNG View Signatures icon in Content Manager and Viewer > Sign menus.   

  task 16 x 16 PNG Manage Tasks icon in Workflow menu.   

  taskcomplete 16 x 16 PNG Manage Tasks > Complete icon in Workflow menu.   

  taskreassign 16 x 16 PNG Manage Tasks > Reassign icon in Workflow menu.   

  ugar 16 x 16 PNG Users, Groups, ACLs & Roles icon in Administration > Configure menu.   

  ugaracls 16 x 16 PNG Configure ACLs icon in Administration > Configure > UGAR menu.   

  ugargroups 16 x 16 PNG Groups icon in Admin > Configure > UGAR menu.   

  ugarroles 16 x 16 PNG 
Configure Roles icon in Admin > Configure > Users, Groups, ACLs and Roles 

menu. 
  

  ugarusers 16 x 16 PNG Users icon in Admin > Configure > Users, Groups, ACLs & Roles menu.   

  usersettings 16 x 16 PNG User Settings icon in Admin menu.   

  view 16 x 16 PNG View icon in Content Manager, Viewer and Workflow menus.   

  viewactualsize 16 x 16 PNG Actual Size icon in Viewer > View > Fit (Image) menu.   

  viewbook 16 x 16 PNG Bookview icon in Viewer menu.   

  viewfit 16 x 16 PNG Fit (Image) icon in Viewer > View > Fit (Image) menu.   

  viewfitbest 16 x 16 PNG Best Fit icon in Viewer > View > Fit (Image) menu.   

  viewfitheight 16 x 16 PNG Fit Height icon in Viewer > View > Fit (Image) menu.   

  viewfitwidth 16 x 16 PNG Fit Width icon in Viewe > View > Fit (Image) menu.   

  viewflip 16 x 16 PNG Flip icon in Viewer > View > Flip menu.   

  viewfliph 16 x 16 PNG Flip Horizontal icon in Viewer > View > Flip menu.   

  viewflipv 16 x 16 PNG Flip Vertical icon in Viewer menu.   
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  viewrotate 16 x 16 PNG Rotate icon in Viewer > View > Rotate menu.   

  viewrotatedefault 16 x 16 PNG Default Orientation icon in Viewer > View > Rotate menu.   

  viewrotateleft 16 x 16 PNG Rotate Left icon in Viewer > View > Rotate menu.   

  viewrotateright 16 x 16 PNG Rotate Right icon in Viewer > View > Rotate menu.   

  viewtoolbar 16 x 16 PNG Hide/Show Toolbar icon in Viewer > View menu.   

  viewzoom 16 x 16 PNG Zoom icon in Viewer > View > Zoom menu.   

  viewzoomabs 16 x 16 PNG Absolute Zoom In icon in Viewer > View > Zoom toolbar.   

  viewzoomin 16 x 16 PNG Zoom In icon in Viewer > View > Zoom menu.   

  viewzoomout 16 x 16 PNG Zoom Out icon in Viewer > View > Zoom menu.   

  viewzoomrb 16 x 16 PNG Rubberband Zoom icon in Viewer > View > Zoom menu.   

  worklist 16 x 16 PNG 
Manage Worklists icon in Workflow and Administration > Configure > Worklists 
menus. 

  

 

2.5.1.2. Messaging Icons  

Note: Images in this section do not have inactive states. 

Image File Name Dimensions Format Reference Description In Library Status 

 

msg-admin-alert 72 x 72 PNG BID Admin alert dialog/message icon.   

 

msg-admin-default 72 x 72 PNG BID Content Manager task dialog/message icon.   

 

msg-admin-error 72 x 72 PNG BID Admin error dialog/message icon.   
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msg-admin-info 72 x 72 PNG BID Admin information dialog/message icon.   

 

msg-admin-success 72 x 72 PNG BID Admin success dialog/message icon.   

 

msg-cm-alert 72 x 72 PNG BID CM (Browse/Search) alert dialog/message icon.   

 

msg-cm-default 72 x 72 PNG BID CM (Browse/Search) default dialog/message icon.   

 

msg-cm-error 72 x 72 PNG BID CM (Browse/Search) error dialog/message icon.   

 

msg-cm-info 72 x 72 PNG BID CM (Browse/Search) info dialog/message icon.   

 

msg-cm-success 72 x 72 PNG BID CM (Browse/Search) success dialog/message icon.   
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msg-help-alert 72 x 72 PNG BID Help alert dialog/message icon.   

 

msg-help-default 72 x 72 PNG BID Help default dialog/message icon.   

 

msg-help-error 72 x 72 PNG BID Help error dialog/message icon.   

 

msg-help-info 72 x 72 PNG BID Help information dialog/message icon.   

 

msg-help-success 72 x 72 PNG BID Help success dialog/message icon.   

 

msg-log-alert 72 x 72 PNG BID Log alert dialog/message icon.   

 

msg-log-default 72 x 72 PNG BID Log default dialog/message icon.   
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msg-log-error 72 x 72 PNG BID Log error dialog/message icon.   

 

msg-log-info 72 x 72 PNG BID Log information dialog/message icon.   

 

msg-log-success 72 x 72 PNG BID Log success dialog/message icon.   

 

msg-rpt-alert 72 x 72 PNG BID Report Manager alert dialog/message icon.   

 

msg-rpt-default 72 x 72 PNG BID Report Manager default dialog/message icon.   

 

msg-rpt-error 72 x 72 PNG BID Report Manager error dialog/message icon.   

 

msg-rpt-info 72 x 72 PNG BID Report Manager information dialog/message icon.   
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msg-rpt-success 72 x 72 PNG BID Report Manager information dialog/message icon.   

 

msg-sec-alert 72 x 72 PNG BID124961 Security alert dialog/message icon.   

 

msg-sec-default 72 x 72 PNG BID124961 Security default dialog/message icon.   

 

msg-sec-error 72 x 72 PNG BID124961 Security error dialog/message icon.   

 

 

msg-sec-info 72 x 72 PNG BID124961 Security information dialog/message icon.   

 

msg-sec-success 72 x 72 PNG BID124962 Security success dialog/message icon.   

 

msg-vwr-alert 72 x 72 PNG BID Viewer alert dialog/message icon.   



  HECM User Interface Style and Standards Guide 

 

- 81 - 

© Copyright 2014 McKesson. Contents are confidential and proprietary. For internal use only. 

 

msg-vwr-default 72 x 72 PNG BID Viewer default dialog/message icon.   

 

msg-vwr-error 72 x 72 PNG BID Viewer error dialog/message icon.   

 

msg-vwr-info 72 x 72 PNG BID Viewer information dialog/message icon.   

 

msg-vwr-success 72 x 72 PNG BID Viewer success dialog/message icon.   

 

msg-wrk-alert 72 x 72 PNG BID Workflow alert dialog/message icon.   

 

msg-wrk-default 72 x 72 PNG BID Workflow default dialog/message icon.   

 

msg-wrk-error 72 x 72 PNG BID Workflow error dialog/message icon.   
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msg-wrk-info 72 x 72 PNG BID Workflow information dialog/message icon.   

 

msg-wrk-success 72 x 72 PNG BID Workflow success dialog/message icon.   

 

2.5.1.3. Button Bar/Toolbar Icons  

Note: Most button bar icons are the same active/inactive files as their cascading menu counterparts. The table below shows those 
that differ or do NOT have equivalent icons in the cascading menu. 

Active Inactive File Name Dimensions Format Description In Library Status 

  contentbin 23 x 16 PNG Content Bin icon   

  dropzone 23 x 16 PNG Drop Zone icon   

 

2.5.1.4. Other Application Icons 

The following icons are listed in no particular order. 

Active Inactive File Name Dimensions Format Reference Description In Library Status 

  asterisk 8 x 7 PNG Style Guide Required field indicator   

  domain 16 x 16 PNG Style Guide BCT domain indicator   

  configuration 16 x 16 PNG Style Guide Generic configuration icon   

  clipboard 16 x 16 PNG Style Guide Clipboard icon   

  clipboardadd 16 x 16 PNG Style Guide Add to Clipboard icon in Content Manager menu.   

  clipboardclear 16 x 16 PNG Style Guide Clear Clipboard icon in Content Manager menu.   

  ugaracl2roles 16 x 16 PNG Style Guide Assign ACLs to Roles   
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  ugarug2roles 16 x 16 PNG Style Guide Assign User/Groups to Roles   

  viewdragscroll 16 x 16 PNG Style Guide Drag-scroll icon in Viewer > View > Flip menu.   

  taskprocess 16 x 16 PNG Style Guide Manage Tasks > Process icon in Workflow menu.   

  reportcmr 16 x 16 PNG Style Guide CM Report icon in RM > Run Admin Reports menu.   

 N/A diagram 10 x 10 PNG Style Guide Results grid content type indicator   

 N/A document 10 x 10 PNG Style Guide Results grid content type indicator   

 N/A image 10 x 10 PNG Style Guide Results grid content type indicator   

 N/A presentation 10 x 10 PNG Style Guide Results grid content type indicator   

 required 8 x 7 PNG BID123843 Required field indicator key   

 N/A spreadsheet 10 x 10 PNG Style Guide Results grid content type indicator   

 N/A text 10 x 10 PNG Style Guide Results grid content type indicator   

 N/A unknown 10 x 10 PNG Style Guide Results grid content type indicator   

 N/A webpage 10 x 10 PNG Style Guide Results grid content type indicator   

  locksm 8 x 11 PNG Style Guide Results grid file status indicator (locked or unlocked)   

 N/A yes 9 x 8 PNG Style Guide Results grid positive state indicator   

 N/A no 9 x 8 PNG Style Guide Results grid negative state indicator   

 

2.5.2. Special Cases 

2.5.2.1. Animation  

Animation is currently only slated for implementation regarding long file manipulation operations, such as moving within, or adding 
to, HECM (see image below). In general, if a situation arises that warrants the use of animation, limit animation to two instances per 
screen, preferably one. 
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 Figure 77: File Transfer Window Animation Example 

2.5.2.2. Logos  

There is presently no direction on logo use. If a McKesson corporate or product logo is employed, please refer to corporate 
standards regarding their appropriate and approved use. 

2.6. System Messaging 

2.6.1. Types  

Note: Example images below show only the “message type indicator” that appears superimposed over the module. Various 
application components have their own distinct icons (e.g., a lock for Security, a computer display for “Browse”). The icons apply 
only to messaging in dialog boxes, though the descriptions of message types hold for messaging within the main application wi ndow 
as well. 

2.6.1.1. Alert  

 

The Alert is used when the system warns of some serious or negative consequences of the user’s or system’s (in)action, 
excluding errors. It is employed when the user must know and mandatorily act upon a serious non-error condition. The 
modal dialog box often requires confirmation before proceeding and is phrased in the interrogatory. An example would 
be a dialog asking the user “are you sure you want to delete this very important item that will affect all users?”  
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2.6.1.2. Default  

No 
corner 
icon is 
used. 

The Default icon/message combination indicates an “at rest” or an a priori state, in which none of the other message 
categories apply. For example, a logon dialog in the absence of any errors, alerts or informational dialogs would be 
considered “default,” because no adverse effects have yet been encountered. 

2.6.1.3. Error 

 

HECM uses a somewhat configurable, “plug-and-play” Microsoft .NET error messaging solution for errors system-wide: 
in dialog boxes and all the panes. The Error message is self-evident: the system warns of some negative consequences 
of the user’s or system’s (in)action or other problems, such as transfer failures, unsupported types, invalid data or 
incorrect credentials. These messages often suggest specific solution(s). Like an Alert, the user must mandatorily act 
upon the information, because some chain of events has been interrupted. The user must directly intervene and 
comply fully before continuing. 

Note: Disable the blinking icon feature. Customize field and label colors as shown. Tooltip includes specific message.  

 
 Figure 78: HECM Error Handling 

2.6.1.4. Info  

 

The Info message is usually positive or neutral feedback, statements, tips, hints or directions regarding an operation 
the user simply acknowledges (such as clicking “OK”) or can optionally undertake (“Your password expires in x days. Do 
you want to change your password now?” In this case, the user may choose “Change Password” or “Skip”). The system 
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reports a status (or change of status) in a declaratory “FYI” fashion and may phrase voluntary operations as a question. 

2.6.1.5. Success  

 

The Success message can be considered a special type of Info message. It provides the user positive feedback regarding 
an event, especially one that immediately impacts system or personal settings or some aspect of how the user interacts 
with the program. The user simply acknowledges (such as clicking “OK” after a “Something successfully happened”). 
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2.6.2. Inventory  

 Review the following on a line item-by-line item basis, not by section. 

 Due to the amount of BIDs being sent out for review, we are highlighting the messages that pertain only to those BIDs in 
different colors to aid with reviewing messages. 

1. We’ve also added another column with the BID Name to aid in finding/matching messages with BIDs 
2. Here is a table a mapping of highlighted colors to BID 
3. Kudos to Jordan for this helpful tidbit: 

 To search for a particular mapping, launch the find (Ctrl+F) and in the find what enter ^g and then the letter following 
with no space. 

 For example, ^ga will bring up Admin Manage Workflow Worklist, and ^gb will bring up User: Manage Task 
 

Bid(s) BID Name Highlighted Background Color 

124952 Configure Domain Light Blue d 

124951 Configure Content Loader & Configure Content Type Purple f 

123840 Browse Bright Pink g 

123842 Search Muted Red h 

123841 Review Content Bright Orange i 

159113 Drop Zone Light Orange j 

124877 Viewer Yellow Green k 

124958 List/View Log Files Green l 
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2.6.2.1. Alerts 

Bid(s) BID Name Code Message Type / Notes Status 

BID125603 Configure ACLs A004 Are you sure you want to delete the selected ACL? Alert Message  

BID125602 Configure Roles A009 Are you sure you want to delete the selected role? Alert Message  

BID125602 Configure Roles A011 Are you sure you want to remove this role from the selected group? Alert Message  

BID125602 Configure Roles A012 Are you sure you want to remove this role from the selected user? Alert Message  

BID125600 Configure Groups A015 Are you sure you want to delete the selected group? Alert Message  

BID125600 Configure Groups A016 Are you sure you want to remove this group from the selected role? Alert Message  

BID125600 Configure Groups A017 Are you sure you want to remove this user from the selected group? Alert Message  

BID125602 Configure Roles A019 Are you sure you want to remove this ACL from the selected role? Alert Message  

BID125603 Configure ACLs A020 Are you sure you want to remove this role from the selected ACL? Alert Message  

BID124951 
Configure Content Loader & 
Content Type 

A028 Are you sure you want to delete the selected content type? Alert Message f 

BID124951 
Configure Content Loader & 
Content Type 

A029 
The content type selected has associated content and cannot be 
deleted. If this template should no longer be used, uncheck “Active” 
in the general tab so it will no longer be available for new content. 

Alert Message f 

BID124591 
Configure Content Loader & 
Content Type 

A032 
Are you sure you want to remove the selected loader rule from this 
content type? 

Alert Message f  

BID124952 Configure Domains A036 
Deleting a domain will delete all associated domain configuration 
settings and content associated to that domain. Are you sure you 
want to delete this domain? 

Alert Message d 

BID  AW01 Would you like to save your work before switching domains? Alert Message  

BID124976 
Admin: Manage workflow 
worklist 

AW07 Are you sure you want to delete the selected worklist(s)? Alert Message a 

BID124976 
Admin: Manage workflow 
worklist 

AW08 The selected Worklist(s) contain tasks and could not be deleted. Alert Message a 

BID124976 
Admin: Manage workflow 
worklist 

AW09 
Worklists that contain tasks could not be deleted. Only the empty 
worklists have been deleted.  

Alert Message a 
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  AW05 
You have unsaved changes. Would you like to save changes before 
refreshing? 

Alert Message  

  UW09? Are you sure you want to unlink the selected content? Alert Message  

BID124977 User: Manage Task  UW13  
The selected content could not be accessed because you do not have 
the appropriate security rights. 

Alert Message  

BID124977 User: Manage Task  UW14  Are you sure you want to unlink content from this task? Alert Message  

BID123843 Submit Content C001 A file by that name already exists. Please rename and submit again. Alert Message  

BID123843 Submit Content C002 
A URL by that name already exists. Use another name or save again 
to have the system uniquely auto-append the name. 

Alert Message  

BID123843 Submit Content C003 The URL or URL name is invalid. Alert Message  

BID124961 Logon User S005 Your password has expired. Please create a new one now. Alert Message  

BID159113 Drop Zone C006 
You do not have security rights to access content in the destination 
folder determined by the content loader.  Do you wish to continue  
adding content to this folder? 

Alert Message j 

BID159113 Drop Zone C008 
The file name your are adding already exists in the destination folder. 
Change the name and add the file again. 

Alert Message j 

BID124962 Configure/Reset Password S020 
To reset your password, correctly answer the following  security 
questions. 

Alert Message  

BID124962 Configure/Reset Password S021 Choose a new password and enter it in both fields below. Alert Message  

BID124964 Configure security policies S025 
Your auto logoff duration is longer than the global duration set by the 
Admin. A duration of <n> minutes will be used. 

Alert Message  

BID124965 Configure security policies S052 
The system will not save work in progress. Are you sure you want to 
log off? 

Alert Message  

BID124965 Configure security policies S053 
The system will not save work in progress. Are you sure you want to 
exit? 

Alert Message  

BID124977 User: Manage Task  UW08 Are you sure you want to delete the selected task(s)? Alert Message  

BID   
This file has been checked out by another user and will be opened in 
read-only mode. 

Alert Message  

BID   Are you sure you want to delete this content and all of its versions?  Alert Message  
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BID   
Are you sure you want to delete the selected version(s) of this 
content? 

Alert Message  

BID   
Deleting this metadata field will delete it from any templates that 
reference it. All associated metadata values will also be deleted. Are 
you sure you want to delete this field? 

Alert Message  

BID   Would you like to save your work before switching domains? Alert Message  

BID   
Deleting this template will delete the template's association to the 
folder, search and check-in screens. Are you sure you want to delete 
this template? 

Alert Message  

BID   
Deleting a domain will delete all associated domain configuration 
settings and content associated to that domain. Are you sure you 
want to delete this domain? 

Alert Message  

BID123843 Submit Content X001 Multiple file operations not supported. Alert Message  

BID1123841 Review Content RC01 Are you sure you want to delete the selected comment? Alert Message i 

BID1123841 Review Content RC02 
Are you have not applied your new comment are you sure you wish 
to continue? 

Alert Message i 

BID1123841 Review Content RC10 Are you sure you want to delete the content(s) and all its versions? Alert Message i 

BID1123841 Review Content RC11 
Are you sure you want to delete the selected version(s) of this 
content? 

Alert Message i 

BID1123841 Review Content RC03 
Content may only be checked out by one user and the selected 
content is already checked out. 

Alert Message i 

BID1123841 Review Content RC04 
Some of the selected content is already checked out and cannot be 
checked out.  Only the content(s) you can check out have been 
checked out. 

Alert Message i 

BID1123841 Review Content RC05 
Content may only be unchecked out by the user who has checked it 
out. 

Alert Message i 

BID1123841 Review Content RC06 
Some of the selected content is checked out by another user and 
cannot be unchecked out.  Only the content you can check out have 
been unchecked out. 

Alert Message i 

BID1123841 Review Content RC07 Content may only be edited by the user who has checked it out. Alert Message i 
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BID1123841 Review Content RC08 
Some of the selected content is checked out by another user and 
cannot be edited.  Only the content(s) you have checked out will 
display to edit. 

Alert Message i 

BID1123841 Review Content RC09 Content may only be checked in by the user who has checked it out. Alert Message i 

  

2.6.2.2. Default 

Bid(s) BID Name Code Message Type / Notes Status 

BID124965 Logoff User S010 The system logged you off due to user inactivity. Default Message  

BID124961 Logon User S051 Enter user ID and password to log on. Default Message  

  

2.6.2.3. Errors 

Bid(s) BID Name Code Message Type / Notes Status 

BID125603 Configure ACLs A005 
An ACL with the same name already exists. Use another name or 
save again to have the system uniquely auto-append the name. 

Error Message  

BID125602 Configure Roles A010 
A role with the same name already exists. Use another name or 
save again to have the system uniquely auto-append the name. 

Error Message  

BID125600 Configure Groups A018 
A group with the same name already exists. Use another name or 
save again to have the system uniquely auto-append the name. 

Error Message  

BID124966 Configure users A022 Missing, unselected or invalid value. Error Message  

BID124966 Configure users A025 User ID is already in use. Please choose another. Error Message  

BID124951 
Configure Content Loader 
& Content Type 

A030 
A content type with the same name already exists. Use another 
name or save again to have the system uniquely auto-append the 
name. 

Error Message f 

BID124952 Configure Domains A035 
A domain with the same name already exists. Use another name 
or save again to have the system uniquely auto-append the name. 

Error Message d 

124957 Configure Logs S055 
The value in this field must be a positive whole number (that is, 
zero or greater than zero).  

Inline-error  
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BID124976 
Admin: Manage workflow 
worklist 

AWE1 Worklist name is already in use. Please choose another name. Error Message  

BID124961 Logon User S001 
The system could not log you on. Please ensure a correct user 
name and password. 

Error Message  

BID124961 Logon User S002 
Your account is locked. Please reset your password by the “Unlock 
Account” button below or contact your administrator. 

Error Message  

BID124961 Logon User S008 The provided value cannot contain more than <n> characters. 

Error Message: 
The value of <n> 
will be determined 
from the variable's 
length definition. 

 

System-
wide 

 S015 
The entered value is invalid. It may be of the wrong data type or 
fails to meet the length requirement. 

Error Message  

BID124964 Configure security policies S016 
The entered value is out of range. Please choose a number within 
the acceptable limits. 

Error Message  

BID124964 Configure security policies S017 
The minimum number of required special characters exceeds the 
maximum password length. 

Error Message  

BID124964 Configure security policies S018 The minimum length exceeds the maximum password length. Error Message  

BID124962 Configure/Reset Password S022 
Security answer(s) incorrect. Please try again. <n> attempt(s) 
remain. 

Error Message: 
The value of <n> 
starts at three (3) 
and decrements 
by one until zero 
(0), then issues 
S023. 

 

BID124962 Configure/Reset Password S023 
This account has been locked. You must contact an administrator 
to gain access. 

Error Message  

BID124963 Change Password S030 
There was an error in creating your new password. The following 
must be corrected before your password can be changed: 

Error Message  

BID124963 Change Password S030a The old password is incorrect. Error Message  

BID124963 Change Password S030b The new password and confirmation password do not match. Error Message  

BID124963 Change Password S030c Passwords must contain <MinLength> to <MaxLength> characters. Error Message  
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BID124963 Change Password S030d 
Passwords must contain at least <PasswordComplexityTest> of 
each: uppercase, lowercase, numeric and symbol characters. 

Error Message: 
This message must 
show only those 
complexity test 
parameters that 
have been 
selected on 
configuration 
password policies 
screen. 

 

BID124963 Change Password S030e 
The proposed new password too closely resembles an old one. 
Please enter a different password. 

Error Message  

BID124963 Change Password S030f The password and user ID cannot be the same. Error Message  

BID124964 Configure Security Policies S054 
The minimum number of required special characters exceeds the 
number of special characters checked above. 

Error Message  

BID123751 Configure Mail Server A038 
IP invalid. Acceptable format is four groups of three digits max, 
separated by dots. For example 255.255.255.255. 

Tooltip - Error  

BID124877 Viewer V001 
This content is unable to display, because a registered 
viewer/player cannot be found. 

Error Message k 

BID   
Content with the same name already exists in this folder. Please 
change the name before submitting the content. 

Error Message  

BID   Try more general keywords. 
Error Message – 
Tooltip 

 

BID   Please ensure that all words are spelled correctly. 
Error Message – 
Tooltip 

 

BID   Try different keywords or keyword combinations. 
Error Message – 
Tooltip 

 

  

2.6.2.4. Tooltips 

Bid(s) BID Name Code Message Type / Notes Status 
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BID165107 
Ext_Userand 
Groups_Worklist 

A038 Save group changes. Tooltip  

BID165107 
Ext_Userand 
Groups_Worklist 

A039 Save changes and create a new group. Tooltip  

BID165107 
Ext_Userand 
Groups_Worklist 

A040 Cancel group changes. Tooltip  

BID165107 
Ext_Userand 
Groups_Worklist 

A041 Save user changes. Tooltip  

BID165107 
Ext_Userand 
Groups_Worklist 

A042 Save changes and create a new user. Tooltip  

BID165107 
Ext_Userand 
Groups_Worklist 

A043 Cancel user changes. Tooltip  

BID124976 
Admin: Manage workflow 
worklist 

AWT01 Save worklist changes. Tooltip  

BID124976 
Admin: Manage workflow 
worklist 

AWT02 Save changes and create a new worklist. Tooltip  

BID124976 
Admin: Manage workflow 
worklist 

AWT03 Cancel worklist changes. Tooltip  

BID  AWT04 Save changes before switching domains. Tooltip  

BID  AWT05 Do not save changes before switching domains. Tooltip  

BID124976 
Admin: Manage workflow 
worklist 

AWT06 Create a new worklist. Tooltip  

BID124976 
Admin: Manage workflow 
worklist 

AWT07 Delete selected worklist(s). Tooltip  

BID124976 
Admin: Manage workflow 
worklist 

AWT08 Do not delete the selected worklist(s). Tooltip  

BID124977  User: Manage Task UWT06 Refresh worklists. Tooltip  

BID124977  User: Manage Task  UWT20 Own task(s) to reassign or complete. Tooltip  

BID124977  User: Manage Task  UWT21 Return task(s) to the worklist to allow ownership by another. Tooltip  

BID124977  User: Manage Task  UWT23 Complete the task(s). Tooltip  
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BID124977  User: Manage Task  UWT24 Delete selected task(s). Tooltip  

BID124977  User: Manage Task  UWT25 Don’t delete tasks(s). Tooltip  

BID124977  User: Manage Task  UWT22 Reassign task(s) to another worklist. Tooltip  

BID124977 User: Manage Task  UWT18 Create a new task for the selected worklist. Tooltip  

BID124977 User: Manage Task UWT03 Edit task(s) that have been released to a worklist.  Tooltip  

BID124977 User: Manage Task  UWT04 Release task(s) for access by other users. Tooltip  

BID124977 User: Manage Task  UWT05 Browse worklists to reassign task(s). Tooltip  

BID124977 User: Manage Task  UWT07 Cancel task changes. Tooltip  

BID124977 User: Manage Task  UWT08 Reassign task(s) to the selected worklist. Tooltip  

BID124977 User: Manage Task  UWT26 Assign task to the selected worklist.  Tooltip  

BID124977 User: Manage Task  UWT09 Cancel reassign. Tooltip  

BID124977 User: Manage Task  UWT10 Add content bin link(s) to this task. Tooltip  

BID124977 User: Manage Task  UWT11 Remove selected linked content from this task. Tooltip  

BID124977 User: Manage Task  UWT12 Don’t remove selected linked content from this task. Tooltip  

BID124977 User: Manage Task  UWT14 
Save task as a draft. No other users will see the task while it is in 
draft status. 

Tooltip  

BID124977 User: Manage Task  UWT15 
Save task and release to the worklist allowing users to work on the 
task. 

Tooltip  

BID124977 User: Manage Task  UWT19 Create a new task for this worklist. Tooltip  

BID124977 User: Manage Task  TB01 Store links from selected content to attach to a task. Tooltip  

BID123841 Review Content RCT01 Delete selected comment. Tooltip i 

BID123841 Review Content RCT02 Don’t delete comment. Tooltip i 

BID123841 Review Content RCT03 Save and apply the comment to the content version. Tooltip i 

BID123841 Review Content RCT04 Do not save the comment. Tooltip i 

BID123841 Review Content RCT05 Delete the selected content(s). Tooltip i 

BID123841 Review Content RCT06 Don’t delete the selected content(s). Tooltip i 
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BID123841 Review Content RCT07 Delete the selected content version(s). Tooltip i 

BID123841 Review Content RCT08 Don’t delete the selected content version(s). Tooltip i 

BID123841 Review Content RCT09 Check in the content with any updates to the metadata. Tooltip i 

BID123841 Review Content RCT10 
Do not check in the content and disregard any updates to the 
metadata. 

Tooltip i 

BID123841 Review Content RCT11 Return to search results. Tooltip i 

BID123841 Review Content RCT12 Return to browse folder. Tooltip i 

BID123841 Review Content RCT13 Create a new comment for the selected content version.  Tooltip i 

BID123841 Review Content RCT14 Save the entered comment. Tooltip i 

BID123841 Review Content RCT15 Delete the selected comment. Tooltip i 

BID123841 Review Content RCT16 Save changes made to the metadata fields. Tooltip i 

BID123841 Review Content RCT17 
Cancel any changes and reset the metadata fields to the last saved 
state. 

Tooltip i 

BID124597 Configure Logs A046 Save log changes. Tooltip  

BID124597 Configure Logs A047 Cancel log changes. Tooltip  

BID124597 Configure Logs A048 Browse for log location. Tooltip  

BID123842 Search F008 Choose a template from a list. Tooltip h 

BID123842 Search F009 Choose a user from a list. Tooltip h 

BID123842 Search F010 Submit criteria to start search. Tooltip h 

BID123842 Search F011 Clear search form and revert to default settings. Tooltip h 

BID123842 Search F012 Choose the highlighted user. Tooltip h 

BID123842 Search F013 Discard selection and quit user look-up operation. Tooltip h 

BID123842 Search F014 Choose highlighted template. Tooltip h 

BID123842 Search F015 Discard selection and quit template look-up operation. Tooltip h 

BID124877 Viewer V025 Rescale view. Tooltip k 

BID124877 Viewer V004 Rescale view to accommodate entire width. Tooltip k 
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BID124877 Viewer V005 Rescale view to accommodate entire height. Tooltip k 

BID124877 Viewer V006 Rescale view to accommodate entire width and height. Tooltip k 

BID124877 Viewer V007 Reset view to native dimensions. Tooltip k 

BID124877 Viewer V008 Configure font attributes. Tooltip k 

BID124877 Viewer V009 Flip view top to bottom. Tooltip k 

BID124877 Viewer V010 Flip view side to side. Tooltip k 

BID124877 Viewer V011 Reorient view 90 degrees to the right. Tooltip k 

BID124877 Viewer V012 Reorient view 90 degrees to the left. Tooltip k 

BID124877 Viewer V013 Rescale view to accommodate two side-by-side pages. Tooltip k 

BID124877 Viewer V014 Sign selected content. Tooltip k 

BID124877 Viewer V015 Print selected content. Tooltip k 

BID124877 Viewer V016 Email selected content. Tooltip k 

BID124877 Viewer V017 Rescale view. Tooltip k 

BID124877 Viewer V018 Rescale view to accommodate entire width. Tooltip k 

BID124877 Viewer V019 Rescale view to accommodate entire height. Tooltip k 

BID124877 Viewer V020 Rescale view to accommodate entire width and height. Tooltip k 

BID124877 Viewer V021 Reset view to native dimensions. Tooltip k 

BID124877 Viewer V022 Configure font attributes. Tooltip k 

BID124877 Viewer V023 Flip view top to bottom. Tooltip k 

BID124877 Viewer V024 Flip view side to side. Tooltip k 

BID124877 Viewer V026 Reorient view 90 degrees to the right. Tooltip k 

BID124958 List/View Log Files A051 Find the next occurrence of the text entered. Tooltip l 

BID124958 List/View Log Files A052 Find a previous occurrence of the text entered. Tooltip l 

BID124958 List/View Log Files A053 Print the log file. Tooltip l 
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BID124958 List/View Log Files A054 Attach the log file to an email message. Tooltip l 

BID124958 List/View Log Files A055 Copy selected log text to the clipboard. Tooltip l 

BID124958 List/View Log Files A056 Save a copy of the log file. Tooltip l 

BID124958 List/View Log Files A092 Connect to location and find HECM components. Tooltip l 

BID124951 
Configure Content Loader & 
Content Type 

A057 Create a new content type. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A058 Delete the selected content type. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A059 Save changes to the content type and content loader rules. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A060 Save changes to the content type and create a new content type. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A061 Discard changes to the content type and loader rules. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A062 Move content loader rule up in the list. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A063 Move content loader rule down in the list. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A064 Create a new content loader rule. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A065 Edit the selected content loader rule. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A066 Delete the selected content loader rule. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A067 Select a folder as the destination for this rule. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A068 Move match condition up in the list. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A069 Move match condition down in the list. Tooltip f 
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BID124951 
Configure Content Loader & 
Content Type 

A070 Create a new match condition. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A071 Edit the selected match condition. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A072 Delete the selected match condition. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A073 Create a new assignment. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A074 Edit the selected assignment. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A075 Delete the selected assignment. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A076 Save the settings for this match condition. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A077 Discard changes to this match condition. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A078 Save settings for this assignment. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A079 Discard changes to this assignment. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A080 Save this rule to the list of content loader rules. Tooltip f 

BID124951 
Configure Content Loader & 
Content Type 

A081 Discard changes to this content loader rule. Tooltip f 

  

2.6.2.5. Headings 

Bid(s) BID Name Code Message Type / Notes Status 

BID125603 Configure ACLs A001 Configure ACLs Heading  

BID125602 Configure Roles A006 Configure Roles Heading  



  HECM User Interface Style and Standards Guide 

 

- 100 - 

© Copyright 2014 McKesson. Contents are confidential and proprietary. For internal use only. 

BID125600 Configure Groups A013 Configure Groups Heading  

BID124951 
Configure Content Loader 
& Content Type 

A026 Configure Content Types Heading f 

BID124952 Configure Domains A033 Configure Domains Heading d 

BID124976 
Admin: Manage workflow 
worklist 

AW02 Configure Worklists Heading  

BID124977 User: Manage Task  UW12  Worklists with Tasks Assigned to You: <w> 

Heading: The value 
of “w” is worklist – 
dynamically 
generated from 
user selection in 
LSP 

 

BID1123841 Review Content RC14 Check In Content Heading i 

BID159113 Drop Zone C004 Add File/URL Heading j 

BID159113 Drop Zone C007 Added Heading j 

BID159113 Drop Zone C009 Field(s) Required for Destination Folder Heading j 

BID124977 User: Manage Task  UW10 Worklists with Tasks You Created: <w> 

Heading: The value 
of “w” is worklist – 
dynamically 
generated from 
user selection in 
LSP 

 

BID124977 User: Manage Task  UW03 Reassign Task(s) Heading  

BID124977 User: Manage Task  UW05 Assign Task Heading  

BID124597 Configure Logs A044 Configure Log Files Heading  

BID123842 Search F004 Select a Metadata Template Heading h 

BID123842 Search F006 Select a User Heading h 

BID124958 List/View Log Files A049 View Log Files Heading l 
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2.6.2.6. Information 

Bid(s) BID Name Code Message Type / Notes Status 

BID124961 Log On User S003 
The system has encountered <n> failed logon attempts. To avoid 
a potential security breach, would you like to change your 
password now? 

Information 
Message: Value of 
<n> is a system 
counter that keeps 
track of failed 
logon attempts. 

 

System-wide   Are you sure you want to log off? 
Information 
Message  

System-wide   
The system will not save work in progress. Are you sure you want 
to exit? 

Information 
Message  

BID124961 Log On User S006 
Your password will expire in <n> days. Would you like to change it 
now? 

Information 
Message  

BID124965 Log Off User S009 
There has been no system activity in the last <n> minutes. This 
session will terminate in 30 seconds. 

Information 
Message: The 
value of <n> 
comes directly 
from configure 
auto logoff 
parameter in BID: 
Configure Security 
Policies. 

 

BID124963 Change Password S013 
To voluntarily change your password, please provide your current 
password and enter a new one twice. 

Information 
Message  

BID124977 User: Manage Task  WI01 
One or more selected task(s) are already owned. Only task(s) that 
are not owned have been marked as owned by you. 

Information 
Message  

BID124977 User: Manage Task WI02  
One or more selected task(s) are not owned by you and cannot be 
returned to the worklist. Only those task(s) that you own have 
been returned. 

Information 
Message  
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BID124977 User: Manage Task WI03  
One or more selected task(s) are not owned by you and cannot be 
marked as completed. Only those task(s) that you own have been 
completed. 

Information 
Message  

BID124977 User: Manage Task  WI06 
One or more selected task(s) are not owned by you and cannot be 
reassigned. Only those task(s) that you own have been 
reassigned. 

Information 
Message  

BID124977 User: Manage Task  WI11 
One or more selected task(s) are already owned and cannot be 
released. Only those task(s) that you own have been released. 

Information 
Message  

BID124977 User: Manage Task  WI13 
Only task(s) that are not owned and in a new status can be edited. 
The task(s) that can be edited have been changed to draft status 
to allow you to edit the task(s). 

Information 
Message  

BID   
This file is currently open. Close the file to complete the check-in 
process. 

Information 
Message 

 

BID   
No content matching your criteria was found. Please refine your 
search. 

Information 
Message 

 

BID   You already subscribe to this folder. 
Information 
Message 

 

BID   
You now subscribe to this folder. An email notification will inform 
you when content in this folder changes. 

Information 
Message 

 

BID   You no longer subscribe to this folder. 
Information 
Message 

 

BID   Select a single version at a time to update metadata. 
Information 
Message 

 

BID   
This content is checked out by another user and cannot be 
deleted. 

Information 
Message 

 

BID1123841 Review Content RC13 Update any metadata associated to this content before check in. 
Information 
Message i 

  

2.6.2.7. Instructions 

Bid(s) BID Name Code Message Type / Notes Status 
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BID125603 Configure ACLs A002 
Choose an ACL from the list below to view, edit or delete it. Select 
the “New” button to create a new ACL. 

Instructions  

BID125603 Configure ACLs A003 
Enter a name and description, and choose security rights for this 
ACL. 

Instructions  

BID125602 Configure Roles A007 Enter a name and description for this role. Instructions  

BID125602 Configure Roles A008 
Select a role from the list below to view, edit or delete, or select 
the “New” button to create a new role. 

Instructions  

BID125600 Configure Groups A014 
Choose a group from the list below to view, edit or delete it. 
Select the “New” button to create a new group. 

Instructions  

BID124591 
Configure Content Loader 
& Content Type 

A027 
Select a content type from the list below to view, edit or delete. 
Select the “New” button to create a new one. 

Instructions f 

BID124591 
Configure Content Loader 
& Content Type 

A031 
Select a rule below to edit, delete or change evaluation order. 
Content Loader evaluates rules in the order they appear. 

Instructions f 

BID124952 Configure Domains A034 
Select a domain from the list below to view, edit or delete. Select 
the “New” button ro create a new one. 

Instructions d 

BID124976 
Admin: Manage workflow 
worklist 

AW03 
Select a worklist from the list below to view, edit or delete.  Select 
the “New” button to create a new worklist. 

Instructions  

BID124977 User: Manage Task  UW17 
Select a task from the list below to view, own, return to the 
worklist, complete or delete.  

Instructions  

BID159113 Drop Zone C005 
Select format, file and template complete metadata fields. 
Content will be uploaded to the server. The destination is 
determined by the content loader rules. 

Instructions j 

BID159113 Drop Zone C010 
Complete the following required fields to continue adding 
content. 

Instructions j 

BID124966 Configure users S027 
Select a user from the list below to view, edit or assign a new 
temporary password. Select the “New” button to create a new 
user. 

Instructions  

BID124977 User: Manage Task  UW01 
Select a task from the list below to view, edit, release or delete. 
You may also create a new task for this worklist. 

Instructions  

BID124977 User: Manage Task  UW04 To reassign task(s) you must enter a reason and select a worklist. Instructions  
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BID124977 User: Manage Task  UI01 
Every task must reside in a worklist. Select either a group or 
personal worklist below to assign to the task. 

Instructions  

BID123751 Configure Mail Server A037 
These settings determine how system-generated email 
is managed. 

Instructions  

BID124597 Configure Logs A045 
Select a source location and component below to view/update log 
settings. 

Instructions  

BID123842 Search F005 
Choose a template from the top list. Review a template’s assigned 
fields from the lower list to help in your selection. 

Instructions h 

BID123842 Search F007 
Choose a user name by last name, first name or ID. To narrow 
your search, enter a value in the text field to find in the list. 

Instructions h 

BID124958 List/View Log Files A050 
Select a source location, component and log file below to view, 
email, copy or save. 

Instructions l 

  

2.6.2.8. Success 

Bid(s) BID Name Code Message Type / Notes Status 

BID124964 Configure security policies S014 The newly configured password policies are now in effect. Success Message  

BID124964 Configure security policies S024 The newly configured auto logoff duration is now in effect. Success Message  

BID124961 Log On User S031 Your password has been successfully changed. Success Message  

BID124977 User: Manage Task  WS01 Task(s) have been successfully reassigned. Success Message  

BID124977 User: Manage Task  WS02 Task(s) have been successfully completed. Success Message  

  

2.6.2.9. Other 

Bid(s) BID Name Code Message Type / Notes Status 

BID124877 Viewer V002 
The viewer does not support this file format. Check out the 
content first and use a third-party application to view it. 

MCP Message k 

BID  V003 No matches found. MCP Message  
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2.6.2.10. Help  

Both static Help (also known as “Global Help” or “Universal Help”) and contextual Help are available for initial release. Universal 
Help (defined as non-specific help that presents all topics at once in sort of an “owner’s manual” fashion) is available principally from 
the main cascading menu. See also hotkeys. Screen-level Help is always available in both the main window and in dialog boxes, 
unless otherwise specified, by the following access points: 

Main Window 
(Contextual Help icon) 

Dialog Boxes 
(Contextual Help button) 

    

2.6.2.11. Tooltips   

Use tooltips throughout the application for two purposes: 

 to elaborate on the function of various controls 

 to provide specific feedback messages (e.g., error details) and helpful tips 

Only use tooltips when they give additional information; never have a tooltip read the same as the label/button text. Toolbar tips 
are readable sentences, punctuated and capitalized as such. They are short, concise and relevant. They do NOT wrap unless so long 
that they would otherwise extend beyond the display’s viewable area. See the Error-handling section for details on tooltip use in 
conjunction with errors. 

Note: column headers do NOT have tooltips. 

2.7. Canned Reports  

2.7.1. Standard Layouts 

More information regarding standard headers, footers, tabular data formats and summary information will occupy this space.  
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2.7.2. Exceptions and Special Cases 

More information regarding special reports and their properties will occupy this space. 
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4.0. Glossary 

4.1. Terms 

4.1.1. A – F 

Arial: a sans serif font common to most major computer operating systems 

Baseline: status of an artifact denoting completion of the formal review process and subsequent approval 

Best practices: methodical, repeatable processes that most efficiently and effectively produce a desired outcome 

Boolean: a complete system for binary operations and algebraic logic named for George Boole, an English mathematician at 
University College Cork in the mid 19th century 

Cascading menu: a collapsing navigation scheme that “unfolds” options from general to specific 

Color(s): 

Analogous – any adjacent colors on the 12-value color wheel 

Complementary – any two colors directly opposite each other on the 12-value color wheel 

Primary – red, yellow and blue, colors impossible to obtain from the mixture of any other colors  

Secondary – green, orange and purple, colors formed by mixing primary colors 

Theory – the idea that color choices affect mood, cognition and perception in positive and negative ways 

ENIGMA: See HECM. 

Extension: the (typically three) letters/numbers after the dot in a file name, indicating the type of file to both the user and the OS  

Grouping: the logical orienting of similar operations in proximity to enhance usability and the overall user experience 

Gutter: the print term, now also common in computer UI parlance, for the space between columns of copy 
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4.1.2. G – L  

Heuristics: best practice “rules of thumb” guidelines learned through experience to produce better quality product 

4.1.3. M – R  

Operation: a specific task a user wishes to accomplish in HECM, such as add new content or configure auto logoff  

Pane: a portion of a window dedicated to certain functions; in HECM panes drive content in other panes 

Sans Serif: a font type lacking serifs 

Pixel: short for “pixel element,” one of the millions of “dots” on your display that comprise the computer’s user interface 

Section 508: portion of the Rehabilitation Act of 1973 – legislation that requires federal agencies to provide disabled employees 
with access to IT resources, such that their experience approximates that of able-bodied employees as much as possible 

Serif: the flairs on the ends of some strokes that make up letters and symbols 

Trebuchet MS: a sans serif font common to most major computer operating systems 

Usability: the measure of how efficient, effective, engaging, error-tolerant and easy to use a product is for meeting users’ needs 

Verdana: a sans serif font common to most major computer operating systems 

4.1.4. S – Z  

No entries. 

4.2. Acronyms 

4.2.1. A – F 

ACL: Access Command List – the list of system permissions and rights assigned to a user role 

BCT: Breadcrumb Trail – the navigable display above the MCP that indicates the user’s current location 

BID: Behavioral and Interactive Design (Document) – See UIS. 
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BMP: Bitmap – a 1- to 24-bit lossless image type that supports neither animation nor transparency 

DIB: Device Independent Bitmap – See BMP. 

4.2.2. G – L  

GIF: Graphics Interchange Format – an 8-bit lossless image type that supports animation and simple transparency 

HECM: Horizon Enterprise Content Manager – McKesson’s content/workflow manager, offspring of HPF 

HPF: Horizon Patient Folder – McKesson’s medical content/workflow manager, forebear of HECM 

JPG (or JPEG): Joint Photographic Experts Group – a 16-bit lossy image type that supports neither transparency nor animation 

LSP: Left Selection Pane – the collapsible left-hand pane in the interface that drives the content of the MCP 

4.2.3. M – R  

MC: Message Center – a designated area in the LSP designed to show tips, help, errors, alerts, logs and other messages to the 
user 

MCP: Main Content Pane – the right-hand larger (2/3 of horizontal space) pane used to display detailed data 

OCD: Object Count Display – the indicator that shows the number of objects in a given folder 

OCD-1 – the object count display associated with the Main Content Pane 

OCD-2 - the object count display associated with the Object Details Pane 

ODP: Object Details Pane – the pane below the MCP that displays details about a selected object  

OOS: Out of Scope – any feature, concept or functionality explicitly excluded from a project for a particular release 

OS: Operating System – a computer program that controls a system’s hardware components and file system, thereby facilitating 
the operation of other specialized programs; examples include Microsoft Windows, MacOS and Linux 

PNG: Portable Graphics Format – a capable 8- to 24-bit image type that supports animation and sophisticated transparency 

PX: Pixel – See Pixel. 
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4.2.4. S – Z  

TBD: To Be Determined – something pending further consideration before a final decision is made  

UCD: User-Centered Design – user interface design that focuses on the user’s goals, mental models, operations and requirements 

UI: User Interface – the system by which a computer user interacts with software and/or hardware to accomplish goals  

UIS: User Interface Specifications – a detailed account of the capabilities, appearance and function of a computer interface, 
formerly known as BID 

URL: Universal Resource Locator – the Web address of, or link to, specific content on the Internet 
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5.2. Changes 

Date Description / Details 

07/12/07 Fixed incorrect inactive Security icons in Admin cascading menu 

07/09/07 Updated dialog box messaging icons 

07/06/07 All official baselining approvals are in and documented; added and highlighted new line-items for subsequent review 

02/06/07 Started HECM UI Style and Standards Guide 

     


